My first test with Blynk 2.0 with example Blink code using ESP8266 board

Please keep in mind, I only tested the blink LED example from BlynkEgent lib. To configure a button on the Blynk app/Blynk website and to turn on and off the on-board LED. The only way I was able to figure out how to do all this was from a couple independent youtube vids not directly from Blynk. Search “Blynk cloud” on Youtube. There are a couple contributors that walk you through the very basics. The Blynk guys themselves have a lot of catching up to do on the documentation. But the Blynk cloud website is fairly easy to figure out. Add a template, edit the template, add a button widget to the template, pick a virtual pin. Add a button to the app pick the virtual pin.

Configuring all your essential widget details(virtual pins) are now done from the website only. And you make the GUI itself from the Blynk app. You create the virtual pins on the Blynk website, not the app. The virtual pins will be available in the Blynk app once configured on the Blynk website. It was surprisingly easy to make the wifi board connect to my router and I really like that I do not have to hard code the credentials.

The Blynk app connection details are very confusing. It is hard to tell if the device is actually connected to the device through the cloud. So make sure the naming of all items match. So hard to explain. There are Blynk template names, Blynk app device names, hotspot names, and SSID names. Not sure about the correlation between device and templates. They both need the same name to make it work. I spent hours trying to figure this out and I am still confused. But I somehow got it working.

I can’t figure out how to disconnect a device on the app. Would be useful to see connection status. I saw an icon once that displayed offline on the device widget. Now it’s gone. Then I somehow had two devices connected and the second device worked… Hum. The Arduino serial console always indicated blynk is connected through all scenarios. I finally realized, the names were incorrect. Started over. Ugh. I am still in dismay how I got it working on the app. But now I can’t figure out why the button on the Web console on the Blynk site does not work. It did work once then it did not. Overall, there is some work to be done with this new Blynk. But it is a great start.


I’ll try to improve docs based on your explanations. Thank you for your valuable feedback.
Devices that are online, do not display any marker, offline devices show “offline” on the tile.

I have worked with the (Legacy) App for years, and am very good at just figuring out new things on my own… but I totally empathized with your post.

I recently spent hours getting a button to trip a relay using a Wemos D1 Mini, with button and relay shields.

While testing the provisioning, which for me didn’t give any indication in the App that it was doing something… I would see the device, I would click on it, it would disappear from the screen… I just kept retrying, then finally sat frustrated and stared at it for a few moments… only for it to suddenly work???

Air worked flawlessly… once… then kept giving the impression of working, while in the background screen the error was saying incorrect firmware?? Same firmware and only slightly modified sketch as before!

And the dashboard… I just couldn’t get anything to happen on the widgets… finally after posting a few screenshots, it was pointed out that I was in the preview screen, not the live one. Only after figuring out that the magnifying glass icon wasn’t a search icon, but the way to get to the live screen, did the rest make sense… Layout screen, preview screen, live screen. Whew! More steps then getting through airport security.

Then something happened during a manual upload and the WiFi info was erased… the device still broadcast it’s SSID and had the same token, but I could never get it re-reconnected without starting from scratch.

In my view, and admittedly limited testing, it is an overly convoluted combination of steps within the App, library and web interface.

I am not convinced it is up to the level of the Blynk I used to love, and personally, not worthy of the name… Nothing gets done in a “blink” anymore, more like a fit of seizures.

1 Like

So, there is an editor…

A pre-live…

And a live…

Of COURSE there is!! Why make it simple when they can make it overtly complex for complexities sake :man_facepalming:

Thanks @Blynk_Coeur for pointing out the error in my practical/logical ways :laughing:

1 Like

@Solarjunkie Opps, sorry for expanding my rant in your topic… only meant to sympathize with your struggle.

1 Like

No worries. Your comments are on track with my own.


Exactly like in blynk 1.0 - EDIT MODE

That’s a new view because it’s a template, and multiple devices can inherit it. We have no idea for which device we should show the data for (if you have let’s say 50 of them)

Exactly like in Blynk 1.0 - PLAY MODE

So we added one new view, and it broke everything? :smile:

Yes, it can be improved (and we are already working on it), but I think the whole idea of comparing something very new, to something old is not very correct.

Yes, we don’t see horses in front of the cars anymore, but does it make cars worse?

1 Like

Ok got it. This is useful info. I would still like to see an “Online” connection status if possible. Thanks.

On the old Blynk it takes me 3-4 minutes to add a board and create an app to toggle an LED or relay on and off. The new Blynk 2.0 has me baffled. I got a board and a virtual Pin. What happened to the support for all the other boards? You use to be able to select your board, select a digital Pin and DONE! Now its a painstaking task it seems.

1 Like

They are planning on bringing the digital pin control back in the near future. But not sure. But its not a good practise to control a digital pin directly, rather use a virtual pin to do the same… yes it was very simple for noobs to get started ! But that way there will be no learning curve !!!

1 Like

I use only virtual pins. For example use the function callback scheme(i.e BLYNK_WRITE) where you direct the software(capture the virtual pin data) and direct the data into hardware control (digital pin). Works amazingly well.

Virtual pins are much more powerful than digital pins, and even if Blynk re-introduce the ability to use digital pins you would be far better learning how to use virtual pins instead…



I know how to use V pins. My point was that some of the simplicity is gone. Whether you use virtual or digital pins, in the end result is the same… it is either on or off… High or low…

I have Particle Photon and Argon Boards, Arduino Nano 33 IoT, Seeed Studio W600. None of them work… Get compile errors. So far only seems to work on ESP based boards. Even setting parameters correctly in Settings.h files is a no go. :frowning:
The old Blynk works on them with no problem. For some new Blynk is step in the right direction. It’s backwards for me.

I agree, but let’s face it, the time taken to create a project is tiny compared to the time you spend using that project.
Datastreams are much more powerful than simply using virtual or digital pins, and make life simpler when it comes to remembering the function of the pins you use because you give the datastreams logical names. Features like data invalidation are also extremely useful, and that wasn’t possible in the old version.
As new features are added, such as voice assistant integration, then they become even more powerful.
If you’re new to Blynk then there is a much steeper learning curve, and there’s lots of switching between web portal and app to achieve the exults, but I guess that’s the cost of progress towards a more powerful and business orientated product. Ultimately that makes the product more saleable and profitable, and ultimately that’s good for us as we get a reliable product that costs a fraction of what it would cost to develop that ourselves.


Please add more details around that. @vshymanskyy could you please take a look?

I’m just a DIY Maker. Not a business. Just need to turn some relays on and off to control some things around the home. It used to be super simple to do that. Not looking to sell anything. The old Blynk was appealing to folks like me because it was super simple and super inexpensive. I know its the corporate and industrial IoT that pays the bills so we take a back seat.

1 Like

The library does not seem to work with these devices. At least that is what I can tell from my bit of knowledge. I have only been able to get it to work with an ESP32 board. That means to continue using it I am going to have to invest $$$ in completely different hardware. That is if I want to make the switch now to the new Blynk. I will ride out the old for as long as I can.

Exactly which devices are you talking about?


Being a heavy basic user of blynk 1 ,Im not loving this new version , I control most of my house with basic digital commands set up on a Arduino Mega connect using the Arduino IDE which meant no real coding , but great interface, functionality and reliability not to mention ability to set timers from the phone. Ive been using cayenne for my analogue data and some switching and I like way you can alter triggers anytime without re writing code.For me was the advantage of Blynk 1 ,it was so simple and always worked , even with Google home.
So far I have managed to connect a couple of WeMos D1 boards with blynk 2 , but they go off line after 10 minutes and the job of replacing the code on my Arduino Mega with roughly 30 outputs and sketchy connection questions is a worry .


I am the same and agree. The new version is no doubt more powerful. But the simplicity and ease of setup is gone for folks like us. And way more expensive now. Out of reach for me unfortunately.