Logging in to Blynk with telnet?

Hi community,

I was very interested to see that somebody had started a Blynk+LabVIEW project (Blynk with LabVIEW). I have downloaded the files from github, but it seems it has issues with logging in.

It wants to log in to blynk.cloud.cc at port 8442, and the login fails. I have tried to use telnet to log in to the same server / same port without a success, so I assume something has been changed in the past two years since this project got an update.

Can you help me out how should I telnet in to blynk?


This host is no longer used.

Should I ask now which host is in use, or you just want to tell yourself?


Welcome to the Blynk Forum

FYI, you could have also seen it yourself in most every single example sketch provided in the Sketch Builder and spread throughout to this forum (in topics a bit newer than 2 years old) :wink:

Blynk is constantly being developed and improved, so some details in old topics will have changed, but there are vast resources in the Docs, Help Center and Sketch Builder links at the upper right of this page. And the Search tools are your best friend for information gathering.

And if you still have any further questions on how to get Blynk operational for your project, please ask here


(I have tried to read the forums and the internet, but I couldnt find a comprehensive solution. This could be my fault, though)

I have tried blynk-cloud.com:8442 as well (before my first post) with the same result. I just didnt put it into my original post as I somehow had the impression that cloud.blynk.cc is the right one. Which was obviously wrong…

The point though is that I can not connect to blynk-cloud.com either at port 8442. Can you confirm that I SHOULD be able to connect via telnet so it must be something wrong on my end? I use the following telnet command: o blynk-cloud.com 8442

and the response is: Connecting to blynk-cloud.com… Could not open connection to the host, on port 8442: Connection failed

I guess I dont need to open any ports on my computer, but I did open 8442 for both inbound and outbound, which didnt help.


Correct. Telnet should work. Otherwise it means something is wrong on your side.

Any guess what could it be? My arduino projects using the authentication Blynk.begin(auth, ssid, pass); have no problem logging data with Blynk.

I have tried telnet on my cellphone as well using 3G to be independent from my router, but same response. I have tried using telnet on a completely different network and PC, same response.

Usually this is just blocked port. Please try to restart router after you make sure you opened ports.

Oh ok… So I need to open this port on my router (and probably on my PC as well). Thanks for the clarification.

In this case the labview code will not work for me as in the company I work for I dont have access to the network settings. Other option is the REST API, which works for reading and writing values with GET. I am struggling PUT and PUSH but thats an implementation hassle on my end.

Do you block outgoing ports then? That would be a very unusual practice :slight_smile:

So for the company I work for: I dont know… sounds odd, and I have concerns.
My PC at home: I have not checked, but except if this is the default setting of the router then no
My android phone: good question, I dont know, never used telnet from a phone before.

Does it work on your end?