Issues accessing local server from WAN

Apparently a couple of things have changed, among which my provider who updated the firmware and erased all settings…
After setting everything up again I can’t access the local server anymore. I’ve tested:

  • local IP:9443/admin#/dashboard --> works
  • dns name (without 9443 port; so WAN IP address) --> works (as in I can access my router from WAN)
  • setup port fowarding and tested it using an external scanner: --> works (that is: port is open)
  • dns name:9443/admin#/dashboard --> does NOT work. WTF?!? (I’ve tried it also with the WAN IP addres, same result)

I know this is not really a blynk issue, but I can still use the help. Anyone got a clue what is going on?
Same btw for the app, using LAN address works, using WAN (dns name) address does not…

and yes, the port translation is from 9443 to 9443

Maybe you should have new firewall rules?

care to elaborate, not sure what I can do with your reply. To be clear, the local server environment is:
WAN–>Router–>Raspberry Pi

  • The RPI is locally accessible, so no issues there.
  • The router is accessible from WAN so not problems there.
  • The routing from WAN to RPI is where the issue lies.
    The ‘firewall’ of the router and its rules are called: port forwarding, which I did and tested and they’re open.

So which ‘firewall rules’ are you talking about?

1 Like

It was a clue, I don’t know how to help you anymore
All seems to be ok, maybe @PeteKnight has best idea to solve your problem.

Use the cloud server.



Hi @PeteKnight,

I’m talking about this: MASSIVE PROJECT: Wifi powered smart system for multi zone, multi floor - floor-heating system. Powered by Blynk project.
So no, your suggestion does not fit the ‘Simples’ category.
Next to that I want my heating system and data not in the cloud.

I am however still experiencing this issue, because I still have local access its not a major issue currently, but coming winter I would like to have proper access again and I still have not found a solution anywhere.

I’m actually considering switching ISP if I can’t resolve this, but I’m not even sure the issues lies there (they DID change a couple of things though that broke it initially, like wiping all port forward settings from the router…)

Hi @wolph42, it was a somewhat flippant remark because I know nothing about local server setup (except what I’ve read) because I use 100% Blynk cloud.

My personal home automation setup, which is also very complex and has multiple sensors and devices, uses MQTT software running on the ESP devices and a Raspberry Pi that acts as my MQTT and Node-Red server. Node-Red provides the bridge to Blynk (and to Amazon Alexa control) and that’s where my data lives. Although I don’t have Blynk control if the internet is down, I do still have an autonomous system that can be controlled via Node-Red and/or a Nextion touch screen.


Thnx, for the swift reply, nodered is also something I would like to delve into, but thats for another time.

i still hope (although i fear its idle) that someone has a cunning solution to this annoying issue.

Even i am trying to achieve the same !! But i am failing very badly !
I am not understanding things like - is it wrong with
Port blocked from isp
Firewall blocking
Router settings

If i have a basic steps what you are doing now i will try the same and update here if i get any positive results!!

Are you using Noip or Dyndns !? Or something of that kind !? Btw how are you forwarding your router to access it over WAN ?

please provide a link or steps you followed to get the port forwarding… let us try ! Lets see if anyone gets to the solution…

Hi @Madhukesh,

There are not many basics steps, port forwarding is rather straightforward (but entirely dependent on your router, here the steps on mine:
beyond that, there is no firewall on my server as only one port is open. I do use for DNS so I don’t have to use my WAN IP address.
Finally I’ve used: to check the port, which appears to be open according to that website…but I can’t connect to the Blynk server from WAN only LAN which seems to contradict this, so hence the post here…

Hello !!

Can you please tell me what all ports you are forwarding and which sever you are using (Rpi or windows or any other) …
And No-ip needs to be logged in every 30 days are so, else the config will be deleted… Hope you know that.
And see to it whether you service providers are not blocking any port !
Please provide me with additional info like port number and protocol(TCP/UDP)…
I will see if i can port forward on both RPi and windows…

An open port isn’t automatically the same as a working port forward.

What happens if you try something like 81 → 9443?

I always recommend and I think that site has helped (at least) a couple of Blynkers :slight_smile:

Port forward can be a real b*tich under any circumstances - but - it’s highly individual. I’ve posted some “tips and trix” here before that might be of use, otherwise you need to provide a lot more detailed information about your current setup.


I dont have my router listed here !! TP LINK TL-WR820N [810N and 840N] are available.

But the port forwarding settings are almost similar. Now what are the ports to be forwarded ? Is it TCP or UDP ??

I have given my PC a static ip already. In firewall i have allowed the ports !
But the ports are not open !! I have checked it !!

Well… which ports are your RPI listening to? Can you post a screen dump from your routers setup? How’s your configured? Is your certificates in order etc etc… There is like a million things that could be wrong! Take a look at my previous posts on the subject.

i have the server running in windows. And my firewall rules are to allow ports from 80-9443.
in the router page i have forwarded port 9443, 8080, 8440, 8441…
is there any other ports to be forwarded ?

hardware ssl - 8441
http api and websocket - 8080
https api websocket and admin page - 9443
mqqt hardware server - 8440

these are the current settings.

@distans thnx for taking your time to answer this!

given my current situation I can only but agree…still whats exactly the difference? Nothing on the server part changed for sure (haven’t touched that for a year now). Blynk app has changed but I can’t see how that would interfere and apparently my router firmware has been changed by the ISP. Most likely lies there the issue. Still…its rather unclear to me what makes a open port NOT a working port??!

ill give that a shot and let you now.

and ill check that one out. Thnx!

I’m afraid that question is above my pay grade! :smiley: But my experience is to find a solution rather then trying to understand what’s wrong he he.

Check my answer in this thread on how to check what’s going on: