BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

I have a problem with setup local Blynk server to Orange Pi Zero

#1

Hi. I am new to this forum, greetings from me. I have a problem with setup local Blynk server to Orange Pi Zero. I follow all this steps how to install server on Orange Pi but unsuccessful. It says “Server start successfully” and i can connect from browser but i can not connect from android app. is anybody have this problems? Sorry if is wrong topic.
Thanks!

0 Likes

Set up Orange Pi Zero as Blynk Local Server
#2

so, if im getting this correctly, you can contact the server on port 9443 in the browser… but not from the APP on the phone?

Correct?

can you open a browser ON THE PHONE and connect?

0 Likes

#3

Yes correct. And yes i can open on the phone browser.
I tape these in my app:
username: admin@blynk.cc
pass: admin
my local ip port 9443
i try change port to 8443 but nothing
The same situation is when i go on Create New Account, i try put for example:
username: blynktest@blynk.cc
pass: blynktest

0 Likes

#4

what if you tried an older version of the server software?

0 Likes

#5

Welcome to this forum! Just one question as you are new… Did you specify custom server path in your application??

1 Like

#6

Thanks Psoro
You mean on that switch BLYNK or CUSTOM where type ip and port, yes i switch to CUSTOM.
First i install Armbian (Armbian_5.75_Orangepizero_Ubuntu_bionic_next_4.19.20) on SD card with Win32DiskImager. When is finish i put SD card in OPI zero and connect into it with Putty
I change pass and login name to “pi”. For some reason when i tape command “sudo apt-get install default-jre” they show errors like:

E: Failed to fetch http://ports.ubuntu.com/pool/main/c/cupslibcups2_2.2.7-lubuntu2.3_armhf.deb" etc

But when i instal this first:

su -
echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee /etc/apt/sources.list.d/webupd8team-java.list
echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
apt-get update
apt-get install oracle-java8-installer

Then i can tape this “sudo apt-get install default-jre” and continiue without errors, but in the end i still can t connect to server from app, i try this 10 times and still nothing. Is this can be a problem, i connect OPi zero to my internet router (wire) and my phone connect on the same router (wifi) maybe my router have wrong setup. I already use Blynk app for my central heating but is not local server it s run from Blynk cloud, they connect on same router can it affect it? Sry for bad english.

0 Likes

#7

Hi @roky91,
My skills for linux are really (really) limited, I’m sorry, I can’t help you with your commands…
Anyway, I use debian from here and my server works properly after installing java8 and cron…
If you want, I can send you a small guide step by step what I do from zero (fresh installation) to run the server…
Let me know

0 Likes

#8

I would be very grateful if you could send it for me.

0 Likes

#9

No worries, I’ll send you a PM with all instructions I follow.
Keep in mind last server update doesn’t contain java8 version… java10 will be required if you want to keep updating the server at the Orange Pi Zero…

0 Likes