BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

How to setup my Blynk local server so that I can use it from out side my local network


#21

Could you tell the procedure on how you obtained a public IP.

@Msprg is trying to explain it the right way (correct me if I am wrong)

Most ISP’s in India(Assuming you are from India) use dynamic IP and port forwarding features are disabled for domestic users. if you need to have those features you will need to get a static/Public IP address for your router from your ISP (extra charges applicable). Once you have your public configured most of the things you are trying would work.


#22

You can forward any port from your router. But you have to configure your router to do so.
First login to your router >> go to advance settings. Here you will find option to forward port.
Here is the link for more instructions https://portforward.com/router.htm

I used no-ip.com to create my WAN IP. (There are several other software to do the same)
Create a host name [xyz.ddns.net] at no-ip.com. After that download DDNS update client and install it to your sever computer.
After installation login to your router >> go to Advance settings>> DDNS.

[if you want to use no-ip service for free then your created HOST name will be automatically deleted after 30 days and you have to recreate it again]

2018-11-19-155955_1366x768_scrot
[UI will no be the same]


#23

I previously was trying to connect to my home computer through remote desktop connection over the internet. But, I was not able to do so. After some research I found out that my ISP (ACT fibernet) blocks inbound connections and to enable those you will have to take a static IP connection. they took the MAC address of my router and assigned a static(public IP ) for my router. after which I was able to connect to my PC remotely over the internet.
So firstly make sure your router internet IP matches IP displayed by whatismyip website.
Hope this helps.


#24

As I said earlier, this is not so easy as “Just forward those and those, and it will work with a snap of a finger”! Also any service like no-ip.com or dyndns will not work like magic, and thus does not solve everything.
I said:

You said:

But then you said:

So that looks like you does NOT meet the very first requirement, thus, it is a bit unclear, as how you are replying, so, we can try to test this again, so:

  1. Open start menu
  2. Search for “cmd”
  3. Open application “Command prompt”
  4. In the black window wich shold appear, write:
    tracert 80.211.207.110
  5. The output copy and pase here as reply to this post, or just take screenshot of the output.

We will see if that helps, good luck.


#25

My router’s internet IP and Public IP didn’t matches together.
I am not using Windows os I am using linux.
Thanks a lot for your cooperation.


#26

Those are different terms for the same thing… Internet IP == Public IP == WAN IP == the IP your Internet provider gives you … How could they not match for you?


#27

Well, you might not know it, but this is really possible. It may seem strange to you but I am (will be - not to lie) a Network engineer with a few certificates from companies like Cisco, so yup, this is really not even possible, but fairly common. It is the way that ISPs are saving IPv4 addresses. In fact, as IPv6 addresses became pretty common and with high support even on the low end devices, there are so much of them, that ISPs could/should give every person at least one public IPv6. But most of them don´t.


#28

@Msprg not sure if you were responding to me or the OP… but I guess I am lucky as my ISP actually supplies me with two (2) public IPs for free (one by default), same with the other big and small players where I live. Even a small WISP I worked for ages ago handled all the internal routing to give the clients such as required.

So, if as you say is the case for this OP, then I think the issue is that he/she needs to contact said ISP and get that remedied… or forgo the WAN side connection option. Nothing we can do here about it.


#29

On the linux is the steps pretty much the same:

  1. Fire up the terminal,
  2. Write and execute:
    sudo traceroute 80.211.207.110 -I
  3. Post output here…

#30

Well, this does not have to be the truth. He/she is not the only one wich is struggling with this issue. I thought about it, and there is a pretty simple, smart, reliable and cheap way of tricking this “restriction”. I have an idea, but no one on “higher place” to make it happen.

Well, lucky/unlucky - it really depends on things like location, country or competition between IPSs. Somewhere you can get a ton of free public IPs, somewhere you can get one wich you have to pay for, or you even might not be able to get any of ISPs in your reach. You could say lucky, and you could say being on the right place at the right time :smile:


Make local blynk server public
#31

I personally don’t believe in “luck”, rather in faith… but it was just meant as simpler figure of (written) speech :wink:

However, my focus was on that fact that without the OP doing something at their end (AKA talk to their ISP) to get this WAN access through to their internal networks Local Server… then there is nothing much further that we (this forum) can do, except add words :stuck_out_tongue_winking_eye:


#32

akr@akr:~$ sudo traceroute 80.211.207.110 -I
traceroute to 80.211.207.110 (80.211.207.110), 30 hops max, 60 byte packets
1 XiaoQiang (192.168.31.1) 1.215 ms 2.877 ms 3.376 ms
2 10.161.115.1 (10.161.115.1) 9.824 ms 9.821 ms 9.817 ms
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *


#33

Exactly as I expected. For you to be able to provide any kind of server the standard way, you have to have public IP address as your second hop. In the output of this command, your first IP address is 192.168.31.1 and your second is 10.161.115.1

The ranges for private addresses is:

  • 10.0.0.0 to 10.255.255.255
  • 172.16.0.0 to 172.31.255.255
  • 192.168.0.0 to 192.168.255.255

Your first IP is from range 192.168. and to have public IP, your second IP has to be not from private range, yet is says 10.x.x.x so you really need to contact your ISP and explain, that you would like to have a server, so you need public IP - not to be behind double NAT.


#35

ISP says I have to pay 4000 rupees(57.38$ aprox) per year to get public ip on rent. It is not possible for me to spend that much. So instead of buying public ip I will buy “Blynk Charge”, since there is no other way left
Thank you everyone for your cooperation.


#36

NOT SO FAST :smile:

There are still some possibilites (none of them are free unfortunately, except… ) :
For example you can pay for VPS, and in that you can go as low as 95 Indian rupees and possibly lower, with that, you will get custom blynk server running, free ssl certificates, unlimited “Blynk charge”, and you still got fully functional server, where you can get running for example your own webpage or for running other server applications as well as Domoticz and many others. Search for a “VPS server” (fun fact: VPS stands for VirtualPrivateServer, so it should not be needed to search VPS server, but people still call it like that, another is a LED diodes.) or you can try to find FREE VPS, but honestly, for me it was just waste of time as I was not able to find anything useful. You might be more lucky.

…except I can offer you a solution… sort of. As you might deduced already, I have VPS, and I am able to forward your ports outside of your niggard ISP to my VPS. I will let you do it for free, although, I can not guarantee you that my server will have 100% online time neither that there will be running forever, but if you want it as for test before you buy your own VPS, you can do it. I can help you with the configuration if you shall.


#37

Thank you very much for your help.

I am tired of doing so many things now I am using Blynk world wide server, I have 58000 blynk charge on it and it is very simple to use. I think it will do the job. If needed I will ask for your help later, thank you.


#38

Okay then, have a great time!


#39

Hi @Msprg, what OS is your VPS running?

Pete.


#40

Hi, thanks for question
It is running on CentOS 7, 64 bit.