BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

How to integrate Blynk and IFTTT (Google Assistant)

Hi! Today I will show you how to use Blynk and IFTTT.
First of all, you need a project on blynk with a button to control for example an LED or a Relay.
Then download IFTTT from Google Play Store (https://goo.gl/snr4DQ) or from Apple Store (https://goo.gl/FXz1f2)
Now open IFTTT, go to “My Applets” and tap on add on top right corner, click on “this” and then find “Google Assistant” after that choose a trigger and complete all phrases on trigger chosen, click on the tick on the right corner, and now select “that”, find “Webhooks”, “make a web request” and now, in the URL you need to put "http://YOUR_COUNTRY_BLYNK_IP/YOUR_TOKEN_HERE/pin/D7 (D7 = digital 7, change it to turn on or off the pin you want) to find the blynk IP from your country just go to command line on PC and write: ping cloud.blynk.cc. For my country (Portugal) the IP is 139.59.206.133, then the link will look like http://139.59.206.133/545db7988exxxxxda8bae2506b99bc25/pin/D7
after you have your link paste it into URL on IFTTT, choose the method to “PUT”, the “Content Type” to “application/json” and the body you put [“0”] to turn ON (if it is an relay). Now to turn off you need to make all the steps before, only changing the body to [“1”].
Now save all, call your assistant and ask her for the phrase you choose, after that the pin you choose will turn ON or OFF.

Here you can view the screenshots (http://imgur.com/a/hQBrQ)

And feel free to contact me if you have any problems :wink:

You don’t need to choose Google Assistant, you can for example choose a button widget, or sms… Think out of the box!

(sorry for my basic english ;_:wink:

13 Likes

@Fabio_faria First I want to thank you for sharing your project. I tried but I do not know where I’m wrong I have no answers, can you help me? Here’s some of what I did.

1 Like

Thanks for sharing!
I’m attempting to get Google Assistant to read the temperature coming from my NodeMCU.
I followed these instructions and the IFTTT works with Blynk and the API, no problem!
But, how do I get it to read me the temperature?
My sensor is on D4 or do I use V6 (from blynk)… Either way, I’ve tried both with no success.
Thanks!

1 Like

not working…ifttt can response command but led cannot control…can u give some video tutorial?

How can I send a value to a virtual pin instead of just 0 / 1 ?

I want to set the temperature on my thermostat using Google Assistant.

same thing here found a solution yet?

I too want to use data from Blynk thermo-probe on nodemcu to toggle a heater that is controlled by an ifttt compatible app (Ewelink).
Why doesn’t Blynk just join ifttt, it would make life easier and the app more popular.

IFTTT is just very picky about integrations - you need to apply and they may or may not approve you. It also costs money to run your own channel there. And the last: it’s soooo slow :turtle:

I’ve been going in the opposite direction for IFTTT.

I wanted to have Blynk trigger other smart home stuff. For instance, if my 5 year old opens her door after bedtime (usually looking for my wife and I) it flashes the patio light and desk light (made by tp-link).

I use the maker channel to set up a webhook and then I have the NodeMCU send it. I also have these lights tied to buttons in my project and put the webhook in the VPin virtualread.

String host =  "maker.ifttt.com"
client2.connect(host, 80);
String url = "https://maker.ifttt.com/trigger/[your_specific_webhook_and_auth_token]";
client2.print(String("POST ") + url + " HTTP/1.1\r\n" +
                 "Host: " + host + "\r\n" + 
                 "Connection: close\r\n\r\n");
1 Like

A post was split to a new topic: Can Google Assistant (Raspberry pi) tell me the temperature & humidity from my Blynk Sensor

I have tried these steps, but my IFTTT applet returns “Applet skipped.” I look at the detail and see this error message, “Webhooks, Make a web request, Action failed, Action skip message, Unable to make a web request: Error: ESOCKETTIMEDOUT”

Do you know what’s wrong?


help me @Fabio_Faria i followed your steps but i could not succeed…when i browser the webhooks URL i can see this [“1.0”]’
but when i command google assistant turn on but the webhoobs dose not make a request

Your efforts and strategy are fantastic, thank you for sharing this with the community.

I altered the variables for my country code and Auth code but I’m not getting this to work. I think the Google Assistant is working fine because I get the programmed reply. I’m not sure about the web call. I’m getting the following applet feedback. “Unable to make Web request. Your server returned a 500” Any ideas about what I might have done wrong?

Thank you in advance for any support or suggestions.

The URL must work from your browser first. Only then it will work with IFTTT. In some cases, it will work with the browser but not IFTTT if hostnames are used in the URL. This is because your geo and the IFTTT server geo are different. You need to find the IP address that blynk-cloud.com resolves to and use the IP address in the URL.

Google Asst+IFTTT+Webhooks has been working for me for over 6 months flawlessly

I use wemos D1…
i can switch all digital pins through blynk app but i can only switch digital pin 1 with google assistant…
any help?

I followed all the steps but i can´t get a response from google assistant, i think the problem is in the URL but im not sure about that, i typed : ping cloud.blynk.cc. in the command center and got this IP : 45.55.96.146 (México)
So my URL looks like this: http://45.55.96.146/MY_TOKEN/pin/V1
(It doesn´t works if i try to open that link from my PC)

but when i try to use my phrase in google assistant all i get is a web search for my phrase.

Did you try to change the sentence?

1 Like

Try using THIS as a starting point for the URL. You will have to switch out the blynk-cloud.com with the IP address you pinged.

Method should be GET as well.

1 Like

A post was split to a new topic: Not able to control its speed through ifttt (google assistance)

I have a question: do we know that the [“0”] command sets the logical port to Low and [“1”] sets the port to High, what is the command to make a pulse on the port using the Google Assistant?

1 Like