Help with Blynk Server

Hello, I started the Blynk Server for the first time and everything goes well. I can execute the ESP8266 Node menu.

But, after of have updated the server 0.18.2, I can’t do log in or create a new user anymore.

PC “SERVER” are on the WiFi router by the cable. I can’t log in again or create a new user.

Any help will be welcome.

Is the port “443” the good one?

Hello. I’m using the port “8443”.


@mauroviana from Blynk server github page :

NOTE : /path should be real existing path to folder where you want to store all your data.

@mauroviana I think your problem relates to “path”. You shouldn’t be typing “path” you should the typing a pathway to your files. If you use “path” everything is temporary and disappears when you restart the server.

By the way I fixed that in 0.18.3. So when users types non-existing folder they will be warned. Hope it will help in future to avoid such issues.


@Dmitriy I think you should find another way of writing path in your notes as many Blynkers are probably Windows users and path doesn’t mean anything to most of them like it does with those of a Unix background.

I’ll verify the “path” and I’ll post here if be alright.

@Dmitriy whilst we are on the subject what is the correct path format for Windows users.

Let’s say we want data to be in C:\Fred\MyData\ what syntax is the path?

1 Like



@mauroviana note the Unix style “pathway” notation even though you are using Windows.

I still can’t. Maybe I need open a port on my router or install some library on Windows?

I’ve tried this:

And this:

This is all that I’ve:

@mauroviana you need the second notation with forward slashes even though Windows normally uses backslashes. You now need to create a new account because /path never existed.

I know other people are having the same problem.

BEFORE you make the change take clones of any important projects and then you can get up and running again quickly.

The server is running, but the account aren’t created.

@mauroviana were you able to create accounts locally before upgrading to 0.18.2 or did you not use a local server before?

Do you have Telnet on your Windows machine, normally it is disabled by default?

If enabled, what happens when you do:

telnet 8442

Yes, two day ago I’ve done exactly the same thing and works perfectly, and I still played with the Node MCU3.
After I deleted everything that did and updated to “server-0.18.2”

I’ve the Telnet on my Windows but isn’t activated


I activated the Telnet and happened this:

After activated and executed.

@mauroviana actually thinking about it if you are running the server on the same machine as the one you are trying to telnet to it wouldn’t give a connection.

Is definitely the correct IP and is it your working Windows machine and the local server?

I don’t think on this. I’ll try from another machine.

Yes, this IP is from the machine with the server.

I’ve tried from another machine but doesn’t work.

I need go to work now, later I’ll try again.