BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Facebook Login Error

I have a Blynk app that has been running without issue for months. Last night, when trying to log in via “Login with Facebook”, I received an error:

“App Not Setup: This app is still in development mode, and you don’t have access to it. Switch to a registered test user or ask an app admin for permissions.”

This error occurs when logging in from multiple devices. If I try and log in with username and password, I am told I must use Facebook. I have not changed anything about my project recently.

How can I resume functionality?

Blynk 1.0 app is no longer supported for 1 year already. However, you can fix the error above via “Reset Pass” functionality. You’ll need to set a password and you’ll be able to login via password, not facebook.

Facebook turned off our app that we used to login for no reasons. And as the app is no longer supported we won’t fix it.

1 Like

Thank you for your quick reply!
Everything is working normally now.

2 Likes

Thank you Dimitriy, i used to log in with facebook (since i tried to make an account but failed) and i got this error 1675030 (with a slightly different message doe), i went to reset password and to my surprise it worked, i got an email to reset and now i can connect with my email account insted of facebook, thanks again, i hope i wont encounter any more problems for around 3 more months since thats all the time i need to present this project. The new Blynk is counterintuitive and doesnt offer the same functionality, im using an Arduino Mega connected with a esp8266 “shield”, only to send a notification when my pir sensor detects movement, and the only way (that i know of) to connect the esp8266 and the arduino in this fashion is with your libraries <ESP8266_Lib.h> and <BlynkSimpleShieldEsp8266.h>
Thanks again, if this didnt work i had to spend some more money on some other hardware and get a big headache with the new code just a big hassle all around so thanks again and again and again.

Your existing hardware will work with the new version of Blynk.

Pete.

What i meant to say is that i would just buy a more expensive proper wifi shield or an arduino with wifi incorporated, and use the new blynk (since i cant even get to connect with the new blynk with the current hardware) or use another methode like AT commands to connect to wifi and mit app inventor with graphic programming for the android app.

If you can’t get past that point, then why do you think that different hardware will help.
Your existing hardware is capable of working with Blynk IoT.

If you were going to buy different hardware then something like an ESP32 would probably be a better choice than the Maga + ESP-01 combination, and they only cost a few dollars now.

Pete.

I first got the mega to learn on it and then i stuck to it with this project that im on ( a simple security device with lots of sensors and connections that require a lot of pins), then my profesor recomended to add some IoT in the project, so i chose blynk to send notifications to my phone and to check some other data.
Im dont know what im doing wrong (as you said just changing the auth token sounds simple enough but thats not it), i think that going to a “simpler” microcontroler with built in wifi would solve the problem.

No, that’s not all you need to do, as I explained.

The ESP32 generally has plenty of pins for most projects, and has much a much faster processor, more memory and built-in WiFi connectivity.
The Mega is 13 years old, so prehistoric by tech standards.

Pete.

Thank you very much!

Помогите мне тоже разобраться.
Раньше входил через Фейсбук.
Теперь выдает ошибку.
При попытке сброса пароля тоже выдает ошибку после ввода имейла.
Что я делаю не так?
P.s.
Все получилось.
Нужно было обновить версию