BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

ESP8266 01 no respond

#1

After i flash firmware to esp8266 wifi module, the esp8266 does not respond to AT command. Can anyone help?

0 Likes

#2

Are you flashing it with AT firmware, or with your own custom code?

Pete.

0 Likes

#3

This is the firmware i flash :
AiThinker_ESP8266_DIO_8M_8M_20160615_V1.5.4.bin

After flash the esp8266 module, it can’t be connected. no respond to the AT command also.

0 Likes

#4

Check the baud rate… you could be using the wrong one after flash procedure.

0 Likes

#5

If that doesn’t work then maybe use the latest official AT firmware from here:
https://www.espressif.com/en/support/download/at

Pete.

0 Likes

#6

I did tried both 9600 and 115200 also can not.

0 Likes

#7

The firmware also no respond.

0 Likes

#8

I thought the default baud rate was 74880

Pete.

0 Likes

#9

I did tried also uploaded the blink code to the esp8266 module. I noticed the bulltin led(TX) led does not blinking. Is it the esp8266 module got problem?

0 Likes

#10

The esp8266 module is okey when do upload code or doing flashing the firmware.

0 Likes

#11

What’s wrong is it🤔??

0 Likes

#12

If you are trying to work with AT commands then presumably you are hooking up the ESP to an Arduino, right?

Try also 74880 but it’s the baud rate INSIDE the ESP that you need to change if you are using it with an Arduino. Needs to be set to 9600 with the required AT command.

So maybe you are not planning to use an Arduino?

0 Likes

#13

No, i don’t use arduino. I am using USB TTL to do flash or upload code.

0 Likes

#14

No, i don’t use arduino. I am using USB TTL to do flash or upload code

0 Likes

#15

Ok you can use 115200 for all baud rates then.

If you can’t flash the Blynk ESP8266 standalone sketch to your ESP then I would say 99% chance you have it wired up wrongly and you can forget all about nasty AT commands (they are only used when playing with an Arduino).

Do you know how to wire up the ESP?

0 Likes

#16

@TCC Tried that already? Immediately after booting ESP is throwing some info there. This is totally independent of firmware flashed and baudrate set.

0 Likes

#17

Is that a question to @TCC ?

@TCC obviously didn’t realise that ESP’s don’t use AT commands when you flash them with an Arduino sketch like Blynk.

0 Likes

#18

How to upload photo to here? I hit the “upload” can not upload photo. I like to show u the USB TTL , and i connected the GPIO0 to ground make as flash or programm mode. The rest pin are connected to the USB TTL. only the GPIO0 and groung is joined together.

0 Likes

#19

When you make a post there is an icon for file upload.

0 Likes

#20

Sure! :slight_smile:

Are you sure you wired it correctly? Or it is a descriptive shortcut. Certainly you need to wire the CH_PD and it is safe to pull up the RST ( I’m not sure if ESP-01 handles it correctly)

0 Likes