BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Devices doesn't show up in app - Blynk 2.0

Hi,
Why doesn’t my device always show up in the mobile app? Sometimes it has and other times it won’t show up. It shows online on the web dashboard. Is this an app bug or am I missing something?

I think it’s an app bug, same here.

I have to quit app and restart.

I’ve tried quitting the app and restarting and also logging out and back in again but still doesn’t show up. It gets the notifications that the device is online though. This is the iOS app. Seriously though if the app is this buggy the platform is basically useless as we need app access only.

@Eugene please follow up on that

@parrot that’s possible in case you hanve’t create any mobile template. Have you created it ( from the developer mode of the app)?

I have developer mode on in the app and have created a mobile template in the app. Initially my device showed up on the devices and notification screen of the app. But now all I get is a notification when the device goes online but no device shown. I have tried now from a second iPhone and have the same problem. Am I doing something wrong?

Here’s my devices screen

@parrot please send us logs from within the app

Ok logs are sent.

I guess that is an Android issue, I don’t see that on my iPhone, device always shows up.

Actually this problem is on iOS.

@parrot thanks for the logs. I’ve created an internal bug ticket.

1 Like

This must not be an app problem since I’ve just tested out the Android app as well and my device is not shown there either. My remote sensor is online and showing in the web page but although I still have the same prototype made in developer mode the device no longer shows up in devices tab. This device is a cellular data device not WiFi connected.

Interesting, I don’t see that problem at all on my iPhone.

@parrot I checked the logs and found that your device sends tempalteId

MPL8XaCnT3n

But template Id always starts with TMPL word, so looks like you didn’t fully copy the template id.
So that’s not a bug. You need to provide correct Tempalte ID. It should be TMPL8XaCnT3n in your case.

1 Like

Ok I reloaded my sketch and it shows up now. Probably I accidentally deleted the first letter of template ID when I reloaded the sketch to try to get everything working, I’m sorry to waste your time, but don’t understand several things.

  1. Initially everything worked, so the template was copied correctly initially. And then it stopped working when I powered it down and restarted it. I think we haven’t found the initial issue.
  2. Does the template id not matter for the web dashboard to work? Because it has always been working.
  3. Am I the only one having trouble understanding the documentation? :grimacing:
1 Like

No problem. We are here to help.

It works in a bit different way. On the mobile correct template id is mandatory. On web - not. We’ll fix that, so the mobile will show devices without templates as well.

It’s work in progress, a lot of things are not finished or done only partially. Good documentation is a long process.

1 Like

Ok thank you. More documentation will be great and will help the migration from the old Blynk.

I am also facing the same situation as you.!
The web is still working fine.
the devices are working fine but the phone shows the same.

z2964175178549_d535f5793e30e6618401842b85a1b24b|243x500