Change Tile Type Not Working

Hi, I have a couple of WiFi extenders in my house, occasionally I need to restart them (the dark mysteries of WiFi . . .). I have hacked Sonoff devices, reflashed with Blynk so that I can power them off/on remotely when I need to.

Thought I’d change the tile icon in mobile dashboard to the WiFi icon, but when I go to Change Tile Type in the mobile dashboard, and select the tile icon, the change does NOT reflect on the mobile dashboard, even after restarting the app (I’ve noticed a lot of the widgets need an app restart to make change take effect . . .)

Any ideas on how to change the tile icon?


I was able to change the tile icon only once. I have attached an image below.

As you can see, i was able to change the icon of the power strip. But for other tiles, even though i have tried changing the icon, it shows the default icon.

HI, Yes, I can change the icon when I change the tile TYPE (eg change it to a button or gauge etc) - but if you change it back to a non-functioning tile, the icon does NOT change.




I have changed the icon in the settings of IR BLASTER. But you can see in the previous post, the icon is default one.


I remember one of the blynk staff said that this is not yet implemented properly. I searched for it, but couldn’t find that particular post.

1 Like

I’ve never had any joy with these built-in icons.
However, if you go to the Template view in the web console you can upload an image file to the template. Any devices created from this template then have the same image icon in both the web console and the app.



Thnx @PeteKnight , I’ll have a play around with that. Got to say that I’m quite surprised that after such a long development time for Blynk 2.0 that there are still so many quite fundamental bugs with the GUI. As a hobbyist I can live with it and seek workarounds, but looking at some of the plan pricing options, I wouldn’t be impressed if I was trying to get a small business app off the ground.


1 Like

@Bill_Donnelly hello. Thanks for pointing out this specific issue. I jsut chekced it as well. It seems like the app cache issue. After you edited the tile settings - new, changed settings are not fetched (and this is a bug). However, if you pull the tiles screen down (to refresh the screen) you should see the new icon applied. Could you please confirm it works for you after “pulling” instead of “closing app”?

If that’s the case it seems like easy fix and we’ll fix it today. If you can’t make the icon change at all, it seems like something else and we’ll need exact steps (as after pulling it seems to be working)

Nope. I just tried refreshing the page; but it doesn’t update the icon. Btw i am IOS.

Hi @Dmitriy , just tried again a few times - still no luck updating the Tile Image using the inbuilt icons. Same behaviour as described in my original post.

Note that it is only the Image Tile Type that does not update, all the other Tile Types (eg Gauges, Button etc) all update and work as expected.


@PeteKnight thnx for the tip, was able to add wifi icon as an image, looks good.


1 Like

Hm… Maybe that’s because I tested on Android. We’ll check on iOS.