Can't signup to blynk app using local server

i can’t signup to my blynk using local server and also can’t access the administrative UI.
I’m attaching my, log and app screenshot.

#hardware mqtt port

#hardware ssl port

#hardware plain tcp/ip port

#http and web sockets port

#https and web sockets port

#application ssl port

#address to bind to. by default bounded to all interfaces

#by default server uses embedded in jar cert to simplify local server installation.
#provide either full path to files either use '.' for specifying current directory. For instance "./myfile.crt"

#by default System.getProperty("")/blynk used

#folder for logs.

#log debug level. trace|debug|info|error. Defines how precise logging will be.

#maximum number of devices allowed per account

#maximum number of tags allowed per account

#defines maximum allowed number of user dashboards. Needed to limit possible number of tokens.

#defines maximum allowed widget size in KBs as json string.

#user is limited with 100 messages per second.

#maximum allowed number of notification queue. Queue responsible for processing email, pushes, twits sending.
#Because of performance issue - those queue is processed in separate thread, this is required due
#to blocking nature of all above operations. Usually limit shouldn't be reached.

#Number of threads for performing blocking operations - push, twits, emails, db queries.
#Recommended to hold this value low unless you have to perform a lot of blocking operations.

#this setting defines how often we can send mail/tweet/push or any other notification. Specified in seconds

#this setting defines how often we can send webhooks. Specified in miliseconds

#this setting defines how big could be response for webhook GET request. Specified in kbs

#maximum size of user profile in kb's

#number of strings to store in terminal widget

#number of strings to store in map widget

#number of strings to store in lcd widget

#maximum number of rows allowed

#period in millis for saving all user DB to disk.

#period in millis for saving stats to disk.

#max size of web request in bytes, 256 kb (256x1024) is default

#maximum number of points that are fetched during CSV export
#43200 == 60 * 24 * 30 - minutes points for 1 month

#specifies maximum period of time when hardware socket could be idle. After which
#socket will be closed due to non activity. In seconds. Default value 15 if not provided.
#leave it empty for infinity timeout

#enable DB

#enable raw data storage to DB

#size of async logger ring buffer. should be increased for loads >2-3k req/sec

#initial amount of energy



#used for reset password page and certificate generation.
#by default current server IP is taken. could be replaced with more friendly hostname.
#it is recommended to override this property with your server IP to avoid possible problems of host resolving

#email used for certificate registration, could be omitted in case you already specified it in

#network interface to determine server's current IP.
#only the first characters of the interface's name are needed.
#the default setting eth will use the first ethX interface found (i.e. eth0)

#comma separated list of administrator IPs. allow access to admin UI only for those IPs.
#you may set it for to allow access for all.
#you may use CIDR notation. For instance,

# default admin name and password. that will be created on initial server start

#comma separated list of users allowed to create accounts. leave it empty if no restriction required.

Server successfully started

blynk app is showing like this after a long hold

Admin panel UI not showing anysort of response

blynk Log

01:15:15.028 INFO - Using data dir 'C:\Users\hugo\blynkServer\DataFiles'
01:15:15.420 INFO - Region : local. Host :
01:15:20.964 INFO - Initializing gmail smtp mail transport. Username : SMTP host :
01:15:21.008 INFO - Didn't find Let's Encrypt certificates.
01:15:21.008 INFO - Automatic certificate generation is turned ON.
01:15:29.131 INFO - Hardware plain tcp/ip server listening at 8442 port.
01:15:29.135 INFO - Hardware SSL server listening at 8441 port.
01:15:29.139 INFO - Application server listening at 8443 port.
01:15:29.143 INFO - HTTP API and WebSockets server listening at 8080 port.
01:15:29.147 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
01:15:29.147 INFO - Mqtt hardware server listening at 8440 port.

Please help me Respected @Gunner @Fettkeewl @wanek @Dmitriy itriy as I’m in trouble …

  • please post screenshot with your server setting in app

  • your phone is connected to the same local network as the server? (i do not see the wifi icon present on the screenshot)

  • did you ever could log succesfully to this server with app, or this is some new issue?

  • did you ever could open the admin panel in the browser? if yes, what did you changed since than?

Appreciate the respect, but there is no need to call out specific users all the time :wink:

As already mentioned… be sure you have setup your App’s custom Server Setting appropriately as shown here…


@Gunner … I’m really sorry if mentioning annoys you, :cry:

being an absolute beginner I could’nt find any other helping hands than you people. :frowning_face:

I’ve setup custom server in app. still not working

what to do now??

please help.

once again sorry for annoying you.

posted in reply to gunner.

I’m using USB thethering from the same phone to my laptop

yeah… but now i’m trying to make a new server as I formated my PC and lost files (I’ve changed everything including IP)

Not personally annoyed… but it is bad forum behaviour to call out members like that for generic assistance (kinda like… “Mom, mom, mom, mom, mom, mom, mom…:stuck_out_tongue_winking_eye:

Everyone already sees new post indications and will look at them and assist if willing/able.

So your laptop is connected to the internet via your phone, which is also trying to connect to your server, which is supposedly running on your laptop… Hmmm… :thinking:

I am not sure how that will work, as your App assumes it is looking for a server over the phones LAN networking… but your server is actually NOT on your LAN network, rather feeding it’s internet from your phones WAN network (cell provider)… I think that might be part of your problem.

1 Like

@Gunner but before 2 days I’ve connected in the same way and it worked fine.

hm… seldom happens, but now i’m completely agree on all points with sir mister master great big respected @Gunner :wink:

1 Like

Then do whatever you did two days ago :stuck_out_tongue:

amazes me as well :wink:

how can I rectify this problem?

it is still not clear to me, how should your phone connect to your server which runs on your laptop?

via internet.
Actually I connect my laptop to internet using USB tethering from phone.

yeah, i see. but how should your phone find your laptop on the internet?

That means your laptop is getting an IP from your phone (or cell provider)… and may not be the same IP you have in your App.

Check your laptops networking to see what IP is is actually getting.

PS, why can’t your laptop connect to a router or something?? and if you must use your phone for internet connection, then I think a Local Server is not best suited for your needs., particularly as…

yeah, but the static ip is local, not global. the app searches for that ip address on the internet, not on your phone - i think. but maybe i’m wrong here…

by the static IP i’ve assigned to my laptop

i dont have any other option to connect my pc to internet. thats why im using tethering option

yeah, but the static ip is local, not global. the app searches for that ip address on the internet, not on your phone - i think. but maybe i’m wrong here…

for this scenario to work, you should do port forwarding.

Then assign a matching range static IP to your phone and see how that goes :stuck_out_tongue_winking_eye:

Seriously, your phone and LS must be on the same network… not just sharing internet.

but when i started first a week before it worked fine using USB tethering