Can't resize widget

I have same difficulties trying to resize widget.
This behavior is random, some time I can resize, some time not.

I’m on version 2.13.1 - Android 6.0 Huawei P9 Lite.


Please check this build:

To send log from it - go to project’s list, select about option from actionbar and from the about screen - ‘send logs’ options - and share via gmail.

Build has been updated by the same link for more touch logging

Any news on this topic. I seem to be having the same issue. I cannot get some/most of my widgets to resize. I am mostly wanting to increase the size of my history graphs; although even the buttons and value displays wont let me resize them either.

I tried uninstalling and re-installing the APP, but that didn’t work. Any ideas?

After some fiddling, I seem to have a solution. If you first drag the widget down so that it make the project have a scroll, you can then put it on the bottom and resize it. then just move it back up to where you want it.

Not the most elegant solution, but seems to work.

@Toro_Blanco Have you updated to latest app? It has gone through a change or two since this topic issue’s version.

On my Android devices with ver 2.13.4, I find I need to touch and hold a widget for about a second, until it looks like it “raises” from the screen, then I can either move and release, or just release it where it was, and it will show the resizing markers (assuming it is a resizable widget and has room) until I either resize it or simply touch it again to lock it in.

I am running 2.13.4 as well.

I follow the same method as you described for moving and resizing widgets. It has always worked for me in the past. It has been a while since I have needed to resize widgets, so I do not know when this issue first came about. Today, I was messing around with some of my older projects, and figured I would change things around a little to give them a new “feel”. One thought was to enlarge the History Graphs to make them a little easier to read. There was some empty space under it, so I tried, as I usually would, to increase its size. After pressing on the widget as you have described, the widget would “raise”, but it would not get the green box around it with the two little dots to allow resizing. There was space below the graph, and I even moved another widget to make more room. No matter what I did, I could not get the green box to show. I then dragged the history graph down (on accident I must say), and it scrolled it way down to the bottom and BAM the green box was there. I resized it and dragged it back to the top where i wanted it (green box went away).

Not sure WHY or HOW, but it worked. I tried this on some of my other projects, and had the same results.


Still Didn’t Work

After Dragging to Bottom

I think there is some form of “proximity sense” when selecting a widget, that determines whether it has the room to resize or not before displaying the move points… and thus might get confused by surrounding widgets in some cases.

Pity the developer who has to move/resize each widget, in every scenario, to catch any “not in my neighbourhood” attitudes with standoffish widgets :stuck_out_tongue_winking_eye:

I wonder if it might be device related? What phone & Android version are you using?

I keep trying to duplicate the issue on my Nexus 6 phone (v7.0) and Note 8.0 tablet (v.4.4.2), but darn thing keeps working… stoopid 'puters, never fail when you need them too :wink:

I am using a Galaxy S5 (SM-G900V) , and running Android 6.0.1.

I am in the process of downloading one of those recording apps to show my issue. I will post it if I can figure it out.

I used to generate the .MP4
and to convert it to .GIF (and optimize it to under 1MB)

There may be a screen recorder that automatically outputs to GIF… haven’t looked yet.

Interesting… @BlynkAndroidDev any ideas?

Wow, very strange issue. We’ll investigate it on our side, currently, I have no ideas on how it is possible.

@Toro_Blanco could you please tell us - is issue is still there?

Yes, the issue still persists.

It is possible it could be my phone (Galaxy S5). I have an issue with the Enventor Widget as well. I cannot get it to show any events past 4. The events are there and function, but I cannot scroll through them to see or edit them. If I delete one of the ones I can see, then the next one down the list will show.

Blynk Version: 2.14.3
Blynk Cloud Server

@Toro_Blanco ok, thanks. We’ll investigate further.

@Toro_Blanco please send me PM with your login email so we could check something.

You could check this build - reproduce your not resizable widget’s issue and send us log (projects list - info button - about screen - ‘send log’ button)

Do i need to uninstall my current BLYNK app? For some reason it wont let me install it. I did allow installs from unknown sources.