Can't log in to local server with android blynk app

I had the phone app working for about a month on an android phone and an IOS phone. Without making any changes to hardware or software on the client, server or phone app, the android app wouldn’t log in to the local server. The IOS app works fine. I’m using the same parameters on both phones. I’ve tried clearing the data and cache on the phone, reinstalling the app, rebooting the phone. I’m able to connect to the admin interface from the android phone. I’m using port 8444 which I have configured in the file. Does anyone have any suggestions for how to troubleshoot this issue. Thanks.

Odd port…

Read this latest Announcement… does it apply to you?

I just checked the version. I guess when I reinstalled the app in hopes that it would fix my problem I got 2.18.0. I’m assuming that since I’m declaring port 8444 in the default of 443 shouldn’t affect me.

It should. As we not only switched ports but also changed protocol. So new one is on port 9443 (that one that is https.port in

You may remove 8444 and put in https.port 8444. Should work.

1 Like

Still not working. I noticed that even when I put https.port=8444 the server wasn’t listening on that port. It was listening on 8443. In the server log file I see the error message when trying to log in from my phone:
ERROR - Wrong income message format
WARN - User not logged

@Lee Did you restart the server? Is that latest server?

I was running 0.28.9. Now I’m running 0.31.0. Still get the same error message in the server log. I’ve removed everything from the file and am specifying 8443 in the phone app.

It’s working now connecting on 9443. Is this change going to cause me a problem with my IOS phone.

No. If you are on the latest version.

Thanks for your help. Much appreciated!