BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Can't connect to Blynk Wifi

Need help with strange problem. I’m at the initial stage of connecting a device to the new Blynk app.

I’ve set everything up in the Blynk web dashboard. Trying the Blynk example for blinking an led.
Using my iphone12, I look and see the wifi address in the iphone wifi settings. So I know the device is working.

I click read in the app, and is asks if I want to connect to the Blynk wifi. I click JOIN, and it is checking device information. Then is says, “Can’t connect to device”. “The device type is not supported”

I’ve tried this with ESP8266 and also ESP-WROOM-32. Neither will connect.

Which board type have you un-commented in the sketch?
Is the LED on the board flashing when you are trying to provision it?

I don’t really understand this part of the process. Have you clicked “Add Device” in the app? if so, what is the exact series of messages you see in the app?

Pete.

Uncommented #define USE_NODE_MCU_BOARD
Indicator light is blinking
I’m attaching photo sequence of events:

Here is code:

#define BLYNK_TEMPLATE_ID "TMPLKil2uaU8"
#define BLYNK_DEVICE_NAME "LED Blink"

#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG

#define APP_DEBUG

// Uncomment your board, or configure a custom board in Settings.h//
//#define USE_SPARKFUN_BLYNK_BOARD
#define USE_NODE_MCU_BOARD
//#define USE_WITTY_CLOUD_BOARD
//#define USE_WEMOS_D1_MINI

#include "BlynkEdgent.h"

BLYNK_WRITE(V)
{
  int pinValue = param.asInt();
  digitalWrite(15,pinValue);
  
}

void setup()
{
  pinMode(15, OUTPUT);
  Serial.begin(115200);
  delay(100);

  BlynkEdgent.begin();
}

void loop() {
  BlynkEdgent.run();
}

This should be a combined jpg of the sequence

@ZedDog54 please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:
```

Pete.

I think I was able to format the code using the backticks. That’s the first time I ever used them. Please let me know if it didn’t work correctly. Thanks.

Hi Pete. Was I able to post the formatted code properly? I was really hoping to get help on getting connected to the Blynk device. If you could offer any assistance it would be greatly appreciated.

Yes

Your images are difficult to see, especially as they are small and inverted.
Were these screens shots taken when trying to provision the device running the exact code you posted?

Pete.

Yes. These were screen shots from my iphone as I was running the exact code I already posted. I couldn’t post more that 1 photo in this app, so I had to combine them all into 1 jpeg, which made them very small. I can email you the photos if that would help, and I’ll make sure they are ‘right side up’.
I truly appreciate your taking the time to help out! Thank you very much.

What version of the app and Blynk library are you using?
What Board Type and Partition Scheme did you choose in the Arduino IDE?

Pete.

Blynk app on iphon12 is Version 3.2.3(1)
Blynk library in sketch is Blynk by Volodymry Shymanskyy Ver 1.0.0-beta3
Arduino IDE installation is 1.8.15 (Windows Store 1.8.49.0)
Board is ESFP32 DEVKI TV1 (on the board chip is says “ESP-WROOM-32”
Amazon.com description for board is “Xiuxin ESP32 Development Board 2.4GHz Dual Mode Wifi Bluetooth Dual Cores ESP32s Antenna Module Board”

Only on selecting the board ESP32 Dev Module does it show the partition info. I’ve tried the “Default 4MB with spiffs (1.2MB APP / 1.5 MB SPIFFS)”, and “Default 4MB with ffat(1.2MB APP / 1.5MB FATFS)”

Message on Amazon.com from the seller (Xiuxin) says to use the NodeMCU 32s board. That’s the first one I tried.
I’ve tried selecting the following boards from Arduino IDE: NodeMCU 32s, ESP 32 Dev Module, ESP32 Wrover, Node32s, FireBeetle-ESP32

On each of the boards I’ve tried, the sketch compiles and loads without problem. It says on the Blynk app on my phone "Blynk Want to Join Wi-Fi Network “Blynk LED Blink - 2FB0F”, I click the “JOIN” button on the app, then the screen says, “Getting Device Information”, then “Can’t connect to the device”.

I’ve even gone into the iPhone WiFi settings and selected the ESP32 as the WiFi provider and it connects without problem. Then I go back into the Blynk App, and it will say to choose the “Already Connected” selection, which I do. But then it gives the same message, “Can’t connect to the device”

Should be 1.0.1

Pete.

IMG_0636

In this it shows Version 1.0.1 installed. I’m still having the same problem.

Manually delete all of the Blynk libraries then re-install via the IDE.
Once you’ve done this, take the latest example sketch then add your template ID to or and flash it to your board.

Pete.

I deleted all Arduino libraries by deleting the entire folder. Removed and reinstalled the Arduino program from the Windows Store. Still getting the same results. “Can’t connect to the device” and below that is “The device type is not supported”. This is with board being set to “ESP 32 Dev Module”

Even made a completely new template in the Blynk Console and copied the template ID and the Blynk device name to the sketch. Still doesn’t work. Same error “Can’t connect to the device” and below that, “The device type is not supported”

Did you follow all of my instructions?

That’s a bad way to do it, far better to download the installer5 from the Arduino website.

Pete.

On the Arduino website, there was a link to the Windows store to download it.

I know. You should ignore it and download the Windows installer.

Pete.

OK, I’ve uninstalled Arduino, and located the three places on PC where it stored files. Deleted all three folders. Downloaded and installed the Arduino program from the Arduino website. Loaded ESP32 boards into the boards manager. Installed the Blynk library. Pulled up the Edgent_ESP32 example from the examples library. It always goes to the point of “sending board info” , and then shows “Can’t connect to device” and “The device type is not supported”
Here is the output on the serial monitor:

[244] Using default config.

[244]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v1.0.1 on ESP32

[248] --------------------------
[251] Product: Blynk LED
[254] Firmware: 0.1.0 (build Aug 1 2021 19:53:14)
[258] Device: ESP32 @ 240MHz
[261] MAC: 94:B9:7E:D3:64:0C
[264] Flash: 4096K
[266] ESP sdk: v3.3.5-1-g85c43024c
[269] Chip rev: 3
[271] Free mem: 272976
[273] --------------------------
[276] INIT => WAIT_CONFIG
[2892] AP SSID: Blynk Blynk LED-2FB0F
[2892] AP IP: 192.168.4.1
[2893] AP URL: blynk.setup
[22376] WAIT_CONFIG => CONFIGURING
[26011] Sending board info…

So you haven’t un-commented one of the #define USE_ board types. Does the default board type that is defined in Settings.h actually match the board you are using?

Pete.