Cant connect to blynk server

I was using blynk some months ago. It was fine that time but now it suddenly stopped working properly serial monitor says connecting to blynk cloud 80
It shows ip and even connects to wifi but not connecting to blynk. I have nodemcu and connect to internet via wifi. Arduino ide version 1.8.5 and blynk version 0.5.2 from blynk server. Phone android 6.0.1 with latest blynk app. I tried many examples of blynk but nothing worked and app doesn’t show nodemcu as online. My router is dlink dsl 2750u. Please help

1 Like

It is a good idea to keep updated with the Announcement Topics…

It appears you are using the Cloud Server… but still, there have been some port changes. For the App, particularly with Local Server (9443) but also for the devices (moving to port 8080)… that might be the cause of your issue?

Also, have you reflashed your device with the new library? Just updating your IDE isn’t enough :wink: And on that note, when updating after a long time, it is best to completely remove the old libraries BEFORE installing the new ones MANUALLY (AKA, don’t use the IDE Library manager)

If nothing in all that seems to help (unlikely) then post your code here… properly formatted as required in the directions…

Did you have some recent changes in your router config? Maybe some firewalls installed?

I tried using port 8080 but still no luck. I totally uninstalled everything and I downloaded and reinstalled arduino 1.8.5 and blynk library master. I believe App works fine but not device. In serial monitor:

[22783] IP:
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.2 on NodeMCU

[22856] Connecting to
[27856] Connecting to
[32857] Connecting to
[37858] Connecting to

This goes on…

This is the code:

  Download latest Blynk library here:

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials:
    Sketch generator: 
    Blynk community:  
    Follow us:        

  Blynk library is licensed under MIT license
  This example code is in public domain.

  This example runs directly on NodeMCU.

  Note: This requires ESP8266 support package:

  Please be sure to select the right NodeMCU module
  in the Tools -> Board menu!

  For advanced settings please follow ESP examples :
   - ESP8266_Standalone_Manual_IP.ino
   - ESP8266_Standalone_SmartConfig.ino
   - ESP8266_Standalone_SSL.ino

  Change WiFi ssid, pass, and Blynk auth token to run :)
  Feel free to apply it to any other example. It's simple!

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "861bd10b3f654f4ea35ae82ef17db8aa";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Wifi SSID";
char pass[] = "Wifi Pass";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);

void loop()

I didnt do any changes in firewall and didn’t even touch router page.
Please also check whether my auth token is fine. I have changed 3 times.

Please help. What else should I try?

Please add debug and post results here.