BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Can't connect new device in Blynk 2.0 application

Ok sorry. For clarification my wifi SSID is “Network Error”

Ok that makes more sense.

Where are you located. US, Europe, …

I think I see the problem

   #warning "Custom board configuration is used"

You need to define the board type to be esp32

I’m located in Asia. For additional information, I didn’t have any trouble when using and connecting my nodemcu esp8266 but for this project I will be needing to use my esp32 (nodemcu esp-32s) but as you can see you already know what my problem is.

I am seeing that as the problem too but I have already tried uncommenting the provided boards in the code and tried using the board configuration for esp32 dev tool kit but still no luck. For the custom board I am not sure what the exact pin configuration to be added in the settings.h

did you remove the comment for the line of your device

Please post the code

What version of the blynk libraries do yo have installed?

There is no line which include

#define nodemcu esp-32

The only line which defines a board is,

#define USE_WROVER_BOARD
#define USE_TTGO_T7

And this is from the sample sketch of the blynk library. I have already tried uncommenting each one at a time but still face the same problem

I tried searching online and I have managed to find from github same sketch from the same library having this below

#define USE_ESP32S2_DEV_KIT

I tried using it but still can’t manage to add device on the app same problems and same result.

If you know how the pins are defined on your board you can use the custom board.

Do you know what version of the Blynk libraries you have installed?

I am using the latest library version 1.0.1

There are labels on the pins but I am not sure which is for the button, for the led and etc. I can post a picture of the board if you would like?

is it this one
Screenshot(18)

Yep that’s the board I am using

The additional led is gpio2

There are a few other threads with this same problem have you looked at them ?

Ok I will try adding gpio 2 in #define BOARD_LED_PIN

What about for?
#define BOARD_BUTTON_PIN
What gpio pin should I add?

Yes you will need that I am looking to see if I can find that pin number

I only managed to find two other threads.
I tried the solution from one of the thread which is to disable debug (#define APP_DEBUG) but it doesn’t work for me

The other thread somehow doesn’t show any solution.

the BOOT button is connected to GPIO0 so pressing it will pull GPIO0 low.
#define BOARD_BUTTON_PIN 0

I think this would work in settings.h

#define BOARD_BUTTON_PIN            0                     // Pin where user button is attached
 #define BOARD_BUTTON_ACTIVE_LOW     true                  // true if button is "active-low"

 #define BOARD_LED_PIN               2                     // Set LED pin - if you have a single-color LED attached
 //#define BOARD_LED_PIN_R           15                    // Set R,G,B pins - if your LED is PWM RGB
 //#define BOARD_LED_PIN_G           12
 //#define BOARD_LED_PIN_B           13
 //#define BOARD_LED_PIN_WS2812      4                     // Set if your LED is WS2812 RGB
 #define BOARD_LED_INVERSE           false                 // true if LED is common anode, false if common cathode
 #define BOARD_LED_BRIGHTNESS        64                    // 0..255 brightness control

once you get that done press and hold the boot button for 10 seconds

@yowckie you need to edit the custom board configuration to suit your board, as described here:

Pete.