Cannot get blynk ethernet to work (olimex esp32-evb)

Before creating the topic

Have olimex esp32-evb board with wifi and ethernet. Program, a gate controller, runs fine on wifi with all bells and whistles. I would like to use the ethernet connection to connect to blynk. All indicates eth is up, can connect to and (80) as client.

Tried all combinations of blynk.config en blynk. begin before the run command. with just token, with, with ioadress value, Program hangs at blynk.begin. debug says dhcp failed.

Any idea how to solve this.
Am pretty versed in blynk but cannot get any step further.
Ideally i would like the program to check ethernet first and then wifi, but because wifi conflicts with ble, i want to at least have ethernet working.


I think you probably need to establish the Ethernet connection then use Blynk.config() and Blynk.connect() rather than using Blynk.begin().

Maybe this info on the LILYGO Ethernet board, which I think is similar in some ways - but cheaper, may help…


Thanks Pete!
Finally solved it with days and days of try and error.
Got it to get to “Connecting to cloud 80 and 8080” messages. Then no success in connecting.
Finally did not use the BlynkEthernetlibraries but the <BlynkSimpleEsp32.h> as also used for the WiFi as I also saw in your sketch. That did the trick. Crazy. The Ethernet libraries simply did not work in the end even though I had Ethernet working in the rest of code.
Thanks again.
Any idea why the Blynk Ethernet libraries did not work or should not be used?

Glad it’s working.

No idea about the Ethernet issues you were seeing I’m afraid. My approach was simply to take a working example sketch for my board and add-in the Blynk stuff afterwards.