BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk server without internet or wifi router


#1

Hello

I am working on a project that requires the Blynk server to be able to move from location to location. So I have configured my RPi 3 +B to be AP and a hotspot to have direct access via WIFI to the Blynk server but the Blynk app losers connectivity when I remove the Ethernet cable.

All help appreciated.
Thank you


#2

I know it’s hard to explain all the gritty details in a forum post. but combining the subject with the msg, you dont need any internet access… and you probably have a battery pack or something you are using to make the pi mobile? Why are you plugging in the ethernet at all?

so, you have the pi up and running with wifi in ap mode. the clients and the app connect just fine. you plug in the ethernet cable, its still works just fine, then you unplug the ethernet cable and the app quits?


#3

you probably followed these instructions, what ip did you give your wlan card?


#4

hi Ivennard thanks for the reply
Im using a RPi3+B and its going to be installed in a dune buggy, the reason for ethernet is for ssh from my pc
the WIFI connectivity between phone and pi works until I until remove the Ethernet cable
the instructions I followed is related to that


#5

remove this line from your /etc/rc.local

iptables-restore < /etc/iptables.ipv4.nat

REBOOT &
give it another test.


#6

thanks ill give it a go


#7

not sure if this is right
is this what you referring to

Capture


#8

yep, is the iptables line below that? I was reversing the instruction link i posted above.


#9

Capture


#10

so network interface should be removed if so my bridge wont work


#11

ahhh you did the bridge. ok. im with you now. having a bridge would knock out the other link, even though you would’nt think it would/should.

You’ll have to weigh that out for yourself to see what you want down, it sounds like you would rather go without the bridge from your post. So i would undo it.

Now that i think i understand better, i would make an AP with static address from the wlan, offer dhcp… then make the eth0 a static address as well, offering dhcp. remove the bridge setup. when you plug your laptop in, you’ll be able to control the pi, and the as long as blynk server is using the wlan adaptor, all your clients will be able to report in.


#12

you have wlan1 as well… an old setup?


#13

that makes sense
old setup ?
oh so this is running a local Blynk server that should control the RPi3 gpio as well so once I remove the bridge ill get back of the gpio or if you the link on that please send it


#14

in your rc.local, you force down wlan0 and wlan1, then bring both back up again. do you have two wlan cards?


#15

no just one wlan0, wlan1 was created for the bridge I can send you the instruction to check if there is a miss up

so thinking Im starting a fresh setup to avoid incorrect setting I might have missed


#16

a fresh setup might be the right move. Im excited to hear about how you’re using blynk on the dune buggy when you’re all done.


#17

thanks me to Ill send some clips and pics with project instructions

chat as soon as I have the fresh install Ill use the above link
thanks alot for the help


#18

Hi Ivennard I have applied all steps of offical Blynk documents and still no luck
Still can connect to Blynk without an internet connection, I have tried removing the iptables like you said as well same thing
so what I done was setup the AP without a bridge and nothing extra followed by the local Blynk server
there must be something Im missing here


#19

It might be worth you looking through this thread:

Pete.


#20

I cant really find a doc for what i was thinking about, its probably not the norm, but i was basically taking the AP idea from the past link, skipping the routing and natting.
Then, setup the eth0 the same way. you would have two interfaces that are statically assigned and handing out addresses. Too bad the laptop didnt have wireless. problem would be solved.