Blynk program does not function

My program seems as though it has been deactivated. I have not used the program for a while, but it worked in the past and now there’s know functionality at all. Its as though I using the wrong authorization key, but that is not the case. I wonder if my account has been deactivated?


We are using a new server now.

What do I have to do to login to the new server?


Install the latest Blynk libraries and reflash the sketch to your device(s).
Also ensure you have the latest version of the Smartphone app.

I will try that–thanks!


I’m also having problems. The app has three dots swirling in a square. I’m using ver 3.8 of the libraries and app version 1.14.2 which I believe are the latest versions. I to have only experienced the problem now after a short break of inactivity. When I use the serial monitor it says it connected to a valid server .
Connecting to Telstra6D17FD
[1253] Connected to WiFi
[1253] IP:
[1254] Blynk v0.3.8 on NodeMCU
[5001] Connecting to
[5518] Ready (ping: 0ms).

What is wrong please?

Not sure if this is same issue, but my app that has worked well for several months no longer stays connected. I am using v2.5.5 of the App (IoS), v0.18.0 server (on an RPi), and v.38 of the library. The project uses WiFiManager (latest version) to connect to the locally-running Blynk server. When I start up now, I get a series of “Login timeout” messages which I assume indicate I am being continuously disconnected. I have not made changes I can recall, although I have upgraded to v1.6.9 Arduino and the before-mentioned Blynk updates. Any thoughts?
Edit: Add important fact that project runs on Feather HUZZAH ESP2866 from Adafruit.

@drewc228 what do you see in server logs?


Trying to open your link or anything in the docs section results in a blank white screen. I’ve never been able to open the docs section of your website successfully, yet the other tabs open ok. Where can I find this log file?

@Colin_Cochrane is your Government blocking you from seeing Blynk web pages?

Difficult to use Blynk without access to their comprehensive documentation.

I would fix the web access before trying to fix Blynk access.

Usually in same folder where jar file is. blynk.log

The Home, Getting Started and Community pages load ok, but the docs is just blank. Why would my government block just the Docs page?

The docs are the most important.

Are you running a ZX Spectrum or similar?

Google Chrome, and I just searched my entire hard-drive for “blynk.log” with no file found.

Lets start by you telling us all your hardware and software plus internet access system.
When did you last use Blynk?

I believe you are probably using Blynk’s cloud server rather than a local server so you will not have any logs on your hard drive.

It would help us if you provide your sketch.

Ok I use

and here’s the sketch:

  • Blynk is a platform with iOS and Android apps to control
  • Arduino, Raspberry Pi and the likes over the Internet.
  • You can easily build graphic interfaces for all your
  • projects by simply dragging and dropping widgets.
  • Downloads, docs, tutorials:
  • Blynk community:
  • Social networks:
  • Blynk library is licensed under MIT license
  • This example code is in public domain.

  • This example runs directly on ESP8266 chip.
  • You need to install this for ESP8266 development:
  • Please be sure to select the right ESP8266 module
  • in the Tools -> Board menu!
  • Change WiFi ssid, pass, and Blynk auth token to run :slight_smile:


#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "";
char pass[] = "";

void setup()
  Blynk.begin(auth, ssid, pass);

void loop()

And this the screen shot of the blank page:

Yes you are using cloud server so no logs.

So a Dell with Windows 10.

Which ESP do you have?

Remove token, SSID and password from the sketch you have posted, highlight the code and then press the </> button.

I’m assuming you have regular broadband but a major problem somewhere if you can’t read the essential docs in a web browser. Try some other browsers to see if that helps.

Are you based in Australia?

What do you get if you ping

I loaded and I have been able to get the functionality back.
As yet I don’t have the library installed properly, assuming I have the right library, because I can not make it show in the Arduino IDE include library window. But I still have been able to extract the new library files and they have worked to restore my program function.
My library structure is not quite what it should be and when introducing new libraries I am not sure what to do with the old ones.


1 Like