Blynk not connecting?

My problem is the whole thing was working yesterday, then i updated my blynk library to 1.1.0, recomplied as notifications did not arrive ( for some reason reached the limit without sending any? ) , and i had no issue, today i connect everything and nodemcu is connected to my wifi, but it’s offline, tried re-upload code, tried deleting the device and creating new one, tired just basic code, nothing worked, really need help.

Using aurdino Serial coomuncation with nodemcu esp8266
Using web
Blynk server
Blynk Library version 1.1.0

#define BLYNK_TEMPLATE_ID "TMPLtss9Oeof"
#define BLYNK_DEVICE_NAME "Fire Alarm"
#define BLYNK_AUTH_TOKEN "-cmNA1tlnuX1xIOEb385kWn0q8nuAWn3"

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

char auth[] = BLYNK_AUTH_TOKEN;

char ssid[] = "1to8";
char pass[] = "12345678";

BlynkTimer timer;

String prvData;
String data = "-1";

void myTimerEvent()
  if (Serial.available()) {
    data = Serial.readString();
  if (prvData < data) {
    Serial.println("in the if statment");
    // Blynk.logEvent("fire_warning", "Alert : Fire detected...! take action immediately.");
    // Blynk.notify("Alert : Fire detected...! take action immediately.");
    prvData = data;
  Serial.println("before sending data");
  Blynk.virtualWrite(V0, data);


void setup()
  if (Serial.available()) {
    prvData = Serial.readString();
  Blynk.begin(auth, ssid, pass);
  timer.setInterval(1000L, myTimerEvent);


void loop()
{;; // Initiates BlynkTimer

Have you rebooted your router?

Have you tried downgrading to 1.0.1 to eliminate that as a potential issue?

That sounds like a very unsatisfactory hardware arrangement. What is the Arduino doing that couldn’t be done by the NodeMCU?

Your problem is that your NodeMCU’s hardware serial port is being used for communication with the Arduino, and that is preventing you from using it for debugging the connection issue with the Blynk server. If you could see the Blynk debug messages they would almost certainly give you a clue about where the issue lies.

I’d do everything I could to eliminate the Arduino from the equation, and if that really isn’t possible then I’d connect the Arduino to a SoftwareSerial port on the NodeMCU, or create a SoftwareSerial port for debugging and use an FTDI adapter.

The message you received was almost certainly that you’d reached your EVENT limit, not NOTIFICATION limit.
This will be because you haven’t set-up the notification correctly, and because you don’t have any way to prevent multiple events from being triggered for the same alarm situation. This would normally be done us8ng a flag variable.

Once you get connected again you should read this…


many thanks for the help
it turns out that port 80 was busy, and always login timeout
so i changed it into
Blynk.begin(auth, ssid, pass, “”, 8080);
which worked

my project requires aurdino with nodemcu

i shall peek at notifications and update you


hello again, so i got everything working as intended , but sometimes i do not receive the mobile notification ( i can receive it on web log ),
any idea?

Not without more info.

Is this something that’s specified by a tutor as part of a project brief?


Dear pete,
Yes, it’s part of my project requirement , and i just checked that everything works as intended.
thank you very much for giving me some of your time.
Kind regards.