Blynk local server port forwardign

Hi, i need help with my blynk local server for port forwarding information and use my projects outsite my server. I try to setup my router for port forwarding but it still not work. In the app wich ip wan i have to put? the router wan or the public ip of computer?

These should be the same. How are you obtaining your “public ip of computer”?

Do you have a static IP address from your Broadband ISP?
If not, then your public IP address will change from time to time - usually when your router is rebooted.
To overcome this, you need to use a DDNS service like NoIP or DuckDNS and have an update client running on your network (probably on your Blynk server) that updates the DDNS service with your current public IP address.


I see in the router settings a wan ip and if i use a site like i see the public ip of the computer. I have to put that ip on the network card settings?
And when i use noip DDNS i have to use a DNS type A with the public ip?

I’m concerned that your router shows one WAN IP address while an external service thinks you have a different public IP. It could be that your ISP is using a Double NAT system, if this is the case then I don’t think it’s possible to access your server externally.
You should read this topic:

You set-up a Hostname, No DNS Type A records needed with this.
It’ll alutomatically populate with your public IP address when you edit the Hostname.


i just write in the cmd the coomand in the topic, i have to reply you with the output?
so in i have to make a dns, put the hostname in the app and fill the port with 9334?

No, read the rest of the topic to understand how to interpret the results.

Yes, except that in NoIp you are creating a DDNS Hostname and the port is 9443