BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk Local Server on Raspberry Pi and access GPIOs


#1

Can you run Blynk Local Server on Raspberry Pi and also use an Blynk app on Smart phone to use the GPIOs on that same Raspberry Pi?


#2

Yes.


#3

Great… basically how is this done?


#4

You install Blynk as a server, set it up… then install it as a client (WiringPi/C++, NodeJS or Python flavors) and point the client (sketches) to the same IP as the RPi it is running on… done.

http://help.blynk.cc/blynk-local-server

http://help.blynk.cc/how-to-connect-different-hardware-with-blynk


#5

Thanks Gunner.


#6

Don’t forget to search this forum for similar projects… others have done the same thing. Keywords, like Server, Client and RPi should get you many of them.


#7

When I run Blynk client on local server (on Raspberry Pi) I get an error…
It is trying to connect to “blynk-cloud.com 8441”
Should this be configured to the Blynk Local Server running on same Rpi?


#8

As indicated in the Local Server documentation and throughout this forum, hardware port has been 8080 for many, many months now :wink: That port works for Cloud as well… which you seem to be attempting to connect to instead of your Local Server… :thinking:

EDIT I also think 8441 was the old SSL port… not sure and not able to look it up right now.

Yep, old port - https://github.com/blynkkk/blynk-server#quick-local-server-setup

image

What client are you trying? WiringPi, NodeJS or Python? I think you must be using an old reference or something?


#9

8441

Is not longer used. For ssl/tls hardware connections please use 9443 or 443.


#10

Tried to access Blynk Local Server external to my router domain by setting up port forwarding rules on router but not working? Using Raspberry Pi with Node.js to operate gpio’s on Pi. Blynk works when phone app is in the same home domain.
Opened TCP Port 443 external to Port TCP 9443 internal
Opened TCP Port 80 external to Port TCP 8080 internal


#11

Just redirect 8080 external to 8080 internal (to specific server IP) and same with 9443… works just fine when I do that.


#12

Are forgot something most important… silly me.
Have to put my home domain public IP in to the Blynk app on smart phone! I still had the internal address of Rpi in app.
Now works well.
I suppose I should think about installing my own certificates.


#13

4 posts were split to a new topic: Where I have to change from cloud to local in the raspberry local server configuration


#14