Blynk Local server + IFTTT

Hi, having followed several methods posted, i cannot seem to get it working.
Hardware side and blynk project working fine on it’s own, trying to include IFTTT in the equation but without success.

url is http://myipaddress:8443/token/update/D12

router port forw 8443 was already done and working before.

applet setup as google assistant + webhook

Hardware is a SONOFF flashed GPIO 12

android detects correct feedback to command but does not turn switch on

any help will be much appreciated.

It’s port 80 i.e. no port required in the url as http is 80 by default.

just tried that but still not working.

is the gpio 12 written like in the app as D12

i.e /update/D12


Blynk have actually coded GET to do a PUT so use GET.

http://ip/token/update/D12?value=1 per blynkapi · Apiary

If it still doesn’t work you haven’t forwarded enough ports. Read server set up again and come back to us if you don’t see the references to the additional ports.

just tried GET instead of PUT. still not working.
i’ve already got 7443 and 8443 ports forwarded

You did this too?

Port forwarding for HTTP/S API

sudo iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 8080
sudo iptables -t nat -A PREROUTING -p tcp --dport 443 -j REDIRECT --to-port 9443

No i haven’t done this, i didn’t read this anywhere?

As I said in the earlier post, read the docs. It’s in the server docs. Let us know when you have found it and how you missed it so others don’t have the same problem.

are you meaning when i first created my local server?

Did you ever read this doc?

yes that’s how i set the local server up

So why didn’t you set up the iptables referenced in the document?

i think the short answer is because everything i needed was already working, i’m only finding this out because i am now trying IFTTT, and as a consequence we are finding out as we’re going what is missing.

in fairness most of the posts relating to IFTTT in your forum refer to using your blynk server not a local server,

Didn’t you think API would be super useful?

When you have problems with local servers use the cloud and then you know you have not set up the local server correctly.

I wrote my last post before seeing this.
It’s not my forum!!!

Haaaaa, @Costas i’m a 50 year old retired Aerospace guy, i’m not a young coder. it’s called the IOT’s. I’m learning as i go along, i rely upon people like you to assist. Maybe my old brain can’t absorb information as quick as yours.
i thank you for your assistance, it is appreciated.

I stand corrected, i presumed wrongly.

My brain is older than yours then.

1 Like

Well maybe you spent a large chunk of your life in computing, i spent mine keeping Concorde flying.