Arduino NANO with ESP8266 upoad error


i’m new and I need your help. I have an arduino compartible NANO board with an integrated ESP8266. The controller it self is a ATmega328 with 32 KB of flash storage. I want to upload an ESP example sketch but the compiler tells me, that the ESP-library can’t be uploaded on a arduino nano. So I dont know how to set up the arduino. I hope you can help me.

Yes, thats it. Sorry for my bad english, i’m a german student. :slight_smile:

Can you show us which board you have with a link? It may be easier to figure out what’s going wrong.

Yes, of course.


I hope you can help me :slight_smile:

It’s not really a Blynk related thing, but I think there is info here:

You should select the Arduino Nano board in the IDE and use the ESPSoftShield example for Blynk. Because it’s integrated as Shield, not as standalone ESP :slight_smile:

Okay, thanks!

I didn’t know that until now. I selected the Arduino Nano board in the IDE but where do I find the ESPShoftShield expamle? I didn’t find it in the example folder in the library. :slight_smile:

It’s called ESP8266_Shield. It’s under Blynk -> Wifi. Be sure to edit for SoftSerial before uploading :slight_smile:

I uploaded the edited sketch to my arduino but than in the serial console this appears:

[19] Blynk v0.3.7 on Arduino Nano
[520] Connecting to Fritz!Repeater
[1536] Failed to disable Echo

I don’t think that this ist normal/OK. What’s my mistake?

Try reversing the Tx/Rx softserial pins.

I tried reversing the pins and i tryed other prins i found online. It doesn’t work anyway. :frowning:

The code I use:

> #define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
> #include <ESP8266_Lib.h>
> #include <BlynkSimpleShieldEsp8266.h>

> // You should get Auth Token in the Blynk App.
> // Go to the Project Settings (nut icon).
> char auth[] = "****";

> #include <SoftwareSerial.h>
> SoftwareSerial EspSerial(11, 12); // RX, TX

> // Your ESP8266 baud rate:
> #define ESP8266_BAUD 9600

> ESP8266 wifi(&EspSerial);

> void setup()
> {
>   // Set console baud rate
>   Serial.begin(9600);
>   delay(10);

>   Blynk.begin(auth, wifi, "Fritz!Repeater", "********");
> }

> void loop()
> {
> }

I hope anybody can help me. :wink:

I think I read somewhere that Baud should be 19200 because that is what they programmed into the ESP.

It doesn’t work anyway. Is there another possible reason or do I have to buy another Arduino?

Well, I would never thought that would actually come up with this thing, it looked a bit useless to me anyway.

You better get a separate ESP and Arduino. That way you see a lot better what you are doing. The ESP can be programmed stand-alone for Blynk too with the Arduino IDE. Since it has more memory than the Arduino, it’s a better solution anyway.

I use most of my ESP’s standalone and my “main” Arduino for the domotic stuff has an ethernet port so I can connect it reliably to the LAN, because my wifi sucks, lol.

Okay, what Arduino would you prefer? Uno? Mega?
Maybe I will buy an Arduino, an Ethernet shield / an ESP8266 standalone. :wink:

I can see a header on the ESP part of your NanoESP board. You can probably solder some headers on there and try to communicate directly to the ESP with an USB-to-Serial convertor. You may be able to figure out which Firmware runs on the ESP part. I think there are some recommendations as to which firmware you need to run (0.22 I think, not sure, but that is on the forum).

If you access the ESP directly ou can give the AT commands and check the firmware with AT+GMR command.

I could directly access to the ESP part and I entered the AT command, wich gives you the firmware information.


AT version: 20 2015 10:04:26)
SDK version:1.0.0
compile time:Mar 20 2015 11:00:32


But how can I update the firmware? I think that it would solve the problem.

I actually think that is the correct version. You may try setting the baudrate a little slower. I think that can be be done with AT+CIOBAUD=9600 but the command list is on the internet.

It doesn’t work. :frowning:

Then I don’t know whats wrong, but then again, I don’t know how they made that board in the first place. We’ll call in @vshymanskyy because he has more brains then us together, lol. He knows about the firmware versions.

Okay, that will be nice! :slight_smile:

Hi there!
I’m not @vshymanskyy… but I’ll try my best… :wink:
Try with AT+UART_DEF=9600,8,1,0,0