BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Android Open Beta. Version 2.27.2


#70

I am experiencing some LED widget color issues when trying to program the color of the LED from my microcontroller. I am using the color code stipulated in Blynk docs:

The colors don’t correspond on the widget according to the above. For example, yellow is actually orange, and dark blue is actually purple/violet.


#71
  1. You can always check color hex: for example, this yellow - https://www.color-hex.com/color/ed9d00
  2. Different displays could show colors differently.

#72

I was having issues connecting to Blynk via BLE from the previous update. This beta version appears to have resolved the issue. Before using this update i was using a HC 05 bluetooth classic module and noticed that my project would connect to Blynk via this module whether my auth token matched or not. This is still the case with this beta version. When using BLE, however, my project only connects if the auth token is correct. I did not see mention of this before and thought it worth while to mention here.

Also, i noticed that the connection by Bluetooth classic has become quite unstable in this beta version. My project updates values for a few seconds and then does not seem to receive information but i am able to send data to my project ( which i have configure to switch on an LED to test the comms). When i connect my project to another device with the latest non beta version of Blynk, i have a stable Bluetooth classic comms. So its probable there is a bug in the beta version.


#73

If you have issue with beta build - please send us logs from it: open about screen (info button on projects list screen) and click on ‘send logs’, select Gmail app and send the email with the log file. For Bluetooth classic issue - please start the project, reproduce the connection lost and send us the logs.

All sketches should have correct auth token (it is a default task for any sketch), it is strange that it worked for you before without correct token.


#74

For bluetooth sketch are you using latest blynk library 0.6.0 or older?


#75

Thankfully I made that QR here… it retained all my URLs :smiley: Vroom Vromm


#76

I’m uploading new beta build with only one change - fix to Bluetooth connectivity, looks like it happens due to backward compatibility old login command, that stops sketch logic. I’ve added some fixes to it, but if would not help - I will remove backward compatibility.


#77

I will do that as soon as i get the chance to

i am using the the library on Particle’s IDE, 0.5.4. Is there a way to upgrade it?

Thank you, i will give it a try and return with feedback.


#78

#79

I’ve thought the log I received was from you) Looks like somebody else sent the log, in any way - I’ve made some additional fixes.


#80

@Alexis_Cabrera
Thanks, but how will this work on Particles web IDE?


#81

better use arduino IDE

https://www.arduino.cc/en/main/software


#82

@Alexis_Cabrera
Sorry, i think i should have mentioned that i am using Particle’s Photon micro-controller and this is why i am using Particle’s Web IDE. I am not sure if i can use the Arduino IDE to program my Photon, but i will look into this if there is no way of updating particle’s Blynk library.


#83

I think there is a delay …

15-027497


#84

@Alexis_Cabrera
I will ask the folks from the particle forums and see if anything turns up.


#85

Hi @BlynkAndroidDev - did you get a chance to look at the issue I described (in the original message to which this reply is part of)?

Thanks - Steven


#86

Dear Blynk team,

I tried BT classic and BLE with the current Beta version (on 16/2/2019), but it doesn’t work at all.
The last weeks I have spent a lot of time investigating the Bluetooth classic & BLE implementation in Blynk, and hopefully I helped you with it by sending log files. However, I do no longer understand what you are doing, I even start doubting if the Android code is actually tested on real BT classic hardware.

a) Android+Library: login protocol
The login protocol problems started with the introduction of Blynk library 0.6.0 in which some incompatible changes were introduced. As a result

  • in the Android app, some changes were done to handle this in 2.27.2 beta
  • in the Blynk library some changes were done to handle this (in github, not yet in the official release)
    I noticed that the changes in the Android app, made the situation even worse. And by changing the library, the protocol in the Android app even didn’t had to be changed.
    My conclusion: it would be better to revert all changes in the Android app related to the login protocol. The 2.27.1 app connects to the github version of the Blynk library

b) Android: - ping problem
In the version 2.27.1, the app nicely reacts on ping messages 06 00 xx 00 00 with 00 00 xx 00 c8. Please revert the changes in the Android app that made 2.27.2 beta no longer react to ping messages

c) Android: - pull data
When combining version 2.27.1 with the current github version of the library, there is a problem with pull data, which I guess was fixed in 2.27.2 beta

d) Example browser
A lot of people are already complaining for months that BT/BLE doesn’t work when they start with the example code generated in the example generator, because of lacking
#define BLYNK_USE_DIRECT_CONNECT
please fix this.

Some time ago, I had a perfect working solution (100% login, 0% packet loss, 100% automatic reconnection after disconnection) with BT classic running on ESP32. But it is no longer the case …


#87

I’m trying to reproduce. Your device model and android os version?


#88

We are testing the app with ESP32 BLE. If you will send us logs - they will help a lot to understand what is going on your side with the communication (info button on the actionbar of projects list screen will open about screen with ‘send logs’ button - after its click please select Gmail or any email app, so it will fill our email and attach log file).

Currently there are possible issues due to backward compatibility calls using old login command (I’m still not sure about it’s fully removal) if the hardware is not responding on new login command, but I hadn’t reproduced them on my side.

This is beta and it can (and mostly will) have issues, that’s why it has logging support that should be used when you are facing issues with the app.


#89

Hi, thanks I am using an LG V30 (T-Mobile) with Android version 8.0.0 (November security patch level). I am also using a private server, not the Blynk server.