BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

8266 ESP-01 (stand alone) connect to Wi-Fi but not to Blynk

Hi,

I’m new on Blynk and I’m learning how to do things at the same time that I’m testing the different hardware before starting one of my projects. I’m just turning on/off a led.

I already have one NodeMCU ESP8266 working and Im trying the ESP-01 using the same sketch just changed the new “Auth Token” for the new button.
I can ping the ESP-01 and I see in my router that is connected. but in the cellphone app just say “Wasn’t online yet”

-Hardware:
8266 ESP-01
using a USB to ESP-01 Adapter (have a switch to program or uart)
a led connected to the GPIO2

-the app is running on android. is working fine, because I can control the other module.

  • Blynk server

-Blynk Library version: 1.0.0 beta 3

-Code: I’m using the example in the website with no modifications.

#define BLYNK_PRINT Serial
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

char auth[] = "my token is here";

char ssid[] = "REYALLI";
char pass[] = "786444a318954";

void setup()
{
  // Debug console
  Serial.begin(9600);

  Blynk.begin(auth, ssid, pass);

}

void loop()
{
  Blynk.run();

}

First things first, uninstall this library and install 0.6.1 instead and re-test.

In UART mode, what does your serial monitor show?

Try disconnecting the LED and re-testing.

Incidentally, your sketch shows no code to control the LED attached to GPIO2, so I assume that you are planning on using digital pins for your app widgets.
Once you have your current code working, you should forget digital pins and switch to virtual pins for your actual project.

Read this:

Pete.

Thank you for your quick answer…

this library load like 2 times faster than the other.

the serial monitor receive the message that is connecting to blynk-cloud.com an invalid auth token.

I copied and pasted the token one more time to be sure that was not a problem in the copy but still have the same issue.

I leave the led disconnected.

I didn’t add any code because adding the button in the app allow me to turn on/off this port and for now this is the only thing I’m trying. I already read something about the virtual pins, but will read your article too. apparently this is part of the key to do complex system. thank you.

Well, clearly this is the problem.

Try re-generating that auth token in the app and using the new one that is emailed to you.

Pete.

Now is working, I learned that “refresh” in the app create a new token… that was what I did the first time that doesn’t worked but continue using the old token…
I don’t know if the changed of the library did something.

Thank you for your Help.

1 Like