BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

zeRGBa issue with Blynk 2.0 and Blynk IoT

Hi,

I’m trying to move a project from older Blynk version to Blynk IoT (android). Project that controls RGB leds using zeRGBa widget.
There is no longer the merge button on new version of zeRGBa so first I don’t know if I should put V0 (Int) on each of the three parameters in the simple mode tab or use the advanced mode with V0 as a string?
If it’s the string option, how are now passed the parameters? as previously it was an array of Int…
By the way when trying both solution the BLYNK_WRITE(V0) function is never triggered.
I tried with a normal on/off switch and it triggers the function so I assume it’s coming from the zeRGBa widget.
I couldn’t find an example including the zeRGBa widget so either I missed it, either it would really be appreciated…
Thanks a lot for any help

Now it’s called advanced.

It’s just like the old blynk

BLYNK_WRITE(V0) //get rgb
{
   red = param[0].asInt();
   green = param[1].asInt();
   blue = param[2].asInt();

Thanks for your reply John93
It’s still not working for me.
It seems to be coming from the zeRGBa widget itself, maybe a bit buggy with the new version.
I’ll keep testing a bit and if I still can’t fix it, I’ll switch to 3 sliders.
Thanks

It’s more likely to be the way that you’re using it

What data type are you using for your single datastream in Advanced mode?

Pete.

Check this out

It has been fixed, just update the app to the latest version which is 1.3.13

Hi Pete.
I’m using string.
Anyway,I activated the condition and action switches in template’s Automation tab and now it works.
I tried to revert back the switches and it’s still working.
I don’t know what happened but it seems that activating those switches did something.
Anyway thanks all for your help

2 Likes