BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

"You need to update the app. It's outdated."

Hello. This may be a simple problem that I just don’t see the answer to, but I haven’t seen anyone else post about this issue. I am currently working on a project connecting Blynk to an Arduino Nano using an HC-05 Bluetooth module, and an update message seems to be interfering with Blynk reading variables from the Nano. I am running Blynk on an Android Galaxy S7, Android version 8.0.0. Arduino has Blynk library version 0.6.1.

The system has been functioning and reading/writing variables with little issue, but after a few seconds of running the project, a pop-up on the bottom of the screen says “You need to update the app. It’s outdated.” I have checked the Google Play Store where I downloaded it and there does not seem to be any update available (app info says “Current Version: 2.27.21(18.11.2020 12:42:36)” ), and after the pop-up shows up, the value displays on my app stop updating. The Nano continues to receive the variables written to it, but the value display widgets do not reflect the change. Is there any particular reason this may be happening? I haven’t yet found anything that would be the update Blynk seems to think it’s missing and it’s making it difficult to read test variables.

The last one is 2.28.2 beta