WiFi SSL Suddenly no longer working

• Hardware mode: Custom ESP32 Board - WiFi
• Blynk server: blynk.cloud:433
• Blynk Library version: 1.0.1

Suddenly out of nowhere, the firmware I’ve been writing won’t connect to WiFi over SSL, I’ve copied down the default ESP32 SSL firmware and getting similar results. Down below you can see the output of the code.

I’m using the Blynk Endget app and it suddenly stopped working. I’ve tried restarting the router, connecting to a mobile hotspot and tried the non SSL version which worked. However, the Endget will not work without the SSL version it seems.

I don’t seem to be able to ping blynk.cloud:433


  You’ll need:
   - Blynk IoT app (download from App Store or Google Play)
   - ESP32 board
   - Decide how to connect to Blynk
     (USB, Ethernet, Wi-Fi, Bluetooth, ...)

  There is a bunch of great example sketches included to show you how to get
  started. Think of them as LEGO bricks  and combine them as you wish.
  For example, take the Ethernet Shield sketch and combine it with the
  Servo example, or choose a USB sketch and add a code from SendData

// Template ID, Device Name and Auth Token are provided by the Blynk.Cloud
// See the Device Info tab, or Template settings
#define BLYNK_TEMPLATE_ID           "TMPLxxxxxx"
#define BLYNK_DEVICE_NAME           "Device"
#define BLYNK_AUTH_TOKEN            "YourAuthToken"

// Comment this out to disable prints and save space
#define BLYNK_PRINT Serial

#include <WiFi.h>
#include <WiFiClient.h>
#include <BlynkSimpleEsp32_SSL.h>

char auth[] = BLYNK_AUTH_TOKEN;

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk.cloud", 443);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8443);

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!


30] Connecting to Q-light
[    49][D][WiFiGeneric.cpp:831] _eventCallback(): Arduino Event: 0 - WIFI_READY
[   143][V][WiFiGeneric.cpp:272] _arduino_event_cb(): STA Started
[   146][D][WiFiGeneric.cpp:831] _eventCallback(): Arduino Event: 2 - STA_START
[   166][V][WiFiGeneric.cpp:96] set_esp_interface_ip(): Configuring Station static IP:, MASK:, GW:
[  2260][V][WiFiGeneric.cpp:284] _arduino_event_cb(): STA Connected: SSID: Q-light, BSSID: 74:83:c2:27:88:4d, Channel: 11, Auth: WPA2_PSK
[  2261][D][WiFiGeneric.cpp:831] _eventCallback(): Arduino Event: 4 - STA_CONNECTED
[  2299][V][WiFiGeneric.cpp:294] _arduino_event_cb(): STA Got New IP:
[  2299][D][WiFiGeneric.cpp:831] _eventCallback(): Arduino Event: 7 - STA_GOT_IP
[  2302][D][WiFiGeneric.cpp:880] _eventCallback(): STA IP:, MASK:, GW:
[2674] Connected to WiFi
[2674] IP:
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v1.0.1 on ESP32

[  2684][V][ssl_client.cpp:311] stop_ssl_socket(): Cleaning SSL connection.
[  2686][V][ssl_client.cpp:311] stop_ssl_socket(): Cleaning SSL connection.
[2703] Connecting to blynk.cloud:443
[  2703][V][ssl_client.cpp:61] start_ssl_client(): Free internal heap before TLS 268384
[  2704][V][ssl_client.cpp:67] start_ssl_client(): Starting socket
[  3000][V][ssl_client.cpp:143] start_ssl_client(): Seeding the random number generator
[  3002][V][ssl_client.cpp:152] start_ssl_client(): Setting up the SSL/TLS structure...
[  3006][V][ssl_client.cpp:175] start_ssl_client(): Loading CA cert
[  3178][V][ssl_client.cpp:244] start_ssl_client(): Setting hostname for TLS session...
[  3179][V][ssl_client.cpp:259] start_ssl_client(): Performing the SSL/TLS handshake...
[  3191][E][WiFiClientSecure.cpp:135] connect(): start_ssl_client: -1
[  3194][V][ssl_client.cpp:311] stop_ssl_socket(): Cleaning SSL connection.
[3207] Secure connection failed

I guess that you’ve updated to version 2.0.3 of the ESP32 core, in which case it’s a know issue which is solved in the latest release candidate of the core.


Oh, that might just be it, I updated to espressif 32’s 4.2.0 version, which contains arduino core 2.0.2. I downgraded to espressif 32 3.5.0 which is the version I previously were developing on. Which fixed it.

I completely forgot I installed a new version as I switched to a new PC recently.