"WiFi Shield Not Present" - Help!

@Jamin True, as long as he uses the VIN port… but someone might inadvertently use the wrong power port - I should have said “potentially feeding 5v into a 3.3v board:wink:

Besides in @Bill_Donnelly case, it is just adding extra troubleshooting issues. As long as he is tethered to the USB, all he needs is the shared ground.

I would also try different signal ports, just in case PIN13 has issues, or the internal LED circuit is somehow draining a bit of current (the Wemos D1 does have an LED on PIN13, right?).

I thought that would be obvious :smile:

In saying that, I happily run my WeMos D1 mini from 5V plugged in to the 3.3V pin. :slight_smile:

In his case yes, but best practice should mean that the power from the strongest source should be used… the usb being plugged in at the same time wont hurt anything.

Ah, but so would using a shared ground… to one who isn’t… [quote=“Bill_Donnelly, post:35, topic:9565”]
still learning as I go
[/quote]… no offense intended @Bill_Donnelly :)[quote=“Jamin, post:42, topic:9565”]
best practice should mean that the power from the strongest source should be used

Again true… but not something I would toss into a power related troubleshooting fray. I try to follow the K.I.S.S. Principal, when assisting (or asking for assistance, as too often is required :stuck_out_tongue: )[quote=“Jamin, post:42, topic:9565”]
I happily run my WeMos D1 mini from 5V plugged in to the 3.3V pin. :slight_smile:

And I tend to test/use LED’s without a resistor on my UNO’s… but I wouldn’t tell others that… er, opps… just did :blush:

All is good @Jamin I will let you carry on with assistance. Sorry for butting in.

1 Like

Hahah what what? The more help, the better for everyone :smiley: :boom: :boom: :boom: :boom:

1 Like

Thnx guys. Common ground it is. Basic mistake!

In my defence while I was troubleshooting I was watching the cricket and my beer fridge is within arms reach, and it was a hot day . . . :cricket_bat_and_ball::beer::sunny:

Thnx again for your help, :+1: great advice on this and I’ve got some good tips from your other posts!

1 Like

New Zealand vs Bangladesh? :cricket:

Aussie Big Bash League. Saw that the Kiwis has a massive win after giving Bangladesh a huge start!

1 Like

Was an epic come-back! Sooo entertaining! I’ll have to watch the recap on the Big Bash!

Hi Guys,

Just to close the loop on this, I tried it when I home today, breadboard, separate PSU, common earth/Vin etc . . .still not throwing the relay! (on-board LED and External LED work fine).

I tried different relays that I had on the shelf . . .voila! The two single relays on the black boards (top right of image) do NOT throw on 3.3v . . .The single relay on the red board DOES, as do each of the relays on the 4-way board.

So while the lack of common ground would certainly have stopped the relay from stopped working, I shouldn’t have got that far if the relay worked in the first place:rage:

Anyway, all good, tested with the D1 in standalone, 12VDC input, no breadboard, the working relays are fine with the 3.3V logic trigger.

1 Like

Those “faulty” two look to be just transistor triggered, and probably rated for full 5v logic requirements. The remainder all seem to be opto-isolated, and thus the logic triggering would be more “universal”.

1 Like

Correct, had a close look at the boards, the dodgy ones only have a couple of resistors and a single transistor on board. Hardwired for 5V no doubt.

The others are more sophisticated. The 5V ones will be fine for future projects . . .I’ve got a bunch of level converters in the mail . . .anyone need some? :grin:

Thats good to know! I didn’t think you could get a relay module without a level shifter!
Never come across one in my time :cold_sweat: