"WiFi Shield Not Present" - Help!

Hi Guys, I’m new to this and its doing my head in!

I have a doit.com ESP13 WiFi Shield - I can connect it to my home WiFi, I can send and receive data via the Serial Monitor so I knw the sheil is working, however I can NOT get it to work with any of the Blynk sketches!

I have setup the app, i have my token, I followed the instructions but no joy.

Any suggestions on what sketch to use please?


Hello. Do you use it as standalone chip? What sketches did you try?

Hi, i’n using it with Arduino board.

I CAN manually setup the ESP13 Shield using these instructions (https://fineshang.gitbooks.io/esp8266-based-serial-wifi-shield-for-arduino-user/content/chapter4.html)

This successfully connects to my home WiFi, I can send and receive serial data to the remote IP and see the data with TCP Console and Serial Monitor. I can switch a LED on/off with this remote setup.

When I then run BlynkBlink sketch it uploads OK but the serial monitor displays
“[0] Blynk 0.4.0 on Arduino Uno”
“[0] Getting IP…”

When I run LED_Blink I get the same result

After a minute or so it returns [130466] DHCP Failed!

It stays in this loop.

Help much appreciated

Hi, I tried all the examples in the Blynk_Release_v0.4.0.zip file.

getting Started, BlynkBlynk, quite a few - all failed to pickup the ip address.

any ideas please?


Hey, Just go to Boards_WiFi examples and select esp8266 shield example

Hi Mate, thnx. Good timing, I’ve been doing that just now.


I // out the lines for Mega etc
I include the lines for software SER for UNO, the sketch compiles and uploads OK

SER Monitor shows . . .
[[19] Blynk v0.4.0 on Arduino Uno
[520] Connecting to GoTigers!
[1536] Failed to disable Echo

If I manually configure the shield I can connect to WiFi, port forward, send/rx data etc.
When I reset the shield then try to connect with the sketch it does not work.

It appears the sketch is not uploading the data to the shield?

Please take a look at our wiki page: https://github.com/blynkkk/blynk-library/wiki/ESP8266-with-AT-firmware

OK, thnx, will check it out.

Hi, I had a look at the links, they all talk about standalone ESP8266. I have a shield.

  1. I know it works with my Arduino Uno R3.
  2. I can connect to my WiFi
  3. I can TX serial data characters to a remote console (port forward from my router)
  4. I can RX serial data from the remote console
  5. I can run a sketch on Uno to turn LED on/off in response to sent character.

All this works. The hardware works.

What does not work is the Blynk sketches ( all that i try) do not communicate with the shield.

As a test I left the SSID and PW as your default, this happened:

[19] Blynk v0.4.0 on Arduino Uno
[520] Connecting to YourNetworkName
[1536] Failed to disable Echo

It is not communicating with the ESP13 Shield from www.doit.am

Can I attach an image to show you what I have?


Look, the link I shared is specifically about the AT commands mode (Shield mode)


Suggest you look again as the link is for Shield not standalone.

Also, please don’t hurry.
Most probably you missed something - like to specify correct TX/RX pins or baud rate for SW Serial in Blynk sketch, etc.

Thnx - the link you posted above take me here - https://github.com/blynkkk/blynk-library/wiki/ESP8266-with-AT-firmware

it talks about USB-UART TTL converter and shows a standalone ESP8266 connection diagram?

No, you’re wrong here. It shows basically the schematic of your shield. You don’t need to wire like that - your shield does it for you. You just need to take correct pins and baud, and update them in Blynk example.

OK, thnx. Can you post the link again please, the one im clicking take me to a standalone and taks about USB-UART TTL converter???


Link is correct, just read to the end.

The link is ALL about shields it’s just that there are different versions of shield. The diagram is a shield. The USB-UART TTL is needed for many shield users but not yours.

Study the AT commands in the link, check which firmware you have etc.

Maybe we should improve the article :wink:

Are you seeing this diagram in the link?