Wiffi connection

I made the example of esp8266 shield
And i flashed the firmware for the esp by changing the dip switches to usp-esp. And it flashef without any error.
Then i uplouded the example esp shield to arduino
By changing the dip switches to usp-arduino-esp
And it done without errors
Then i got the esp wiffi on my phone but the blynk still offline.
Please helpe me i dont recognize which step is wrong.
Shall i stay on the main network for blynking or on esp network.

I don’t believe you can connect App directly to ESP running in what sounds like a local access-point mode.

You need access to a Blynk server in order to make everything work APP <-> SERVER (Cloud or Local) <-> MCU (ESP)… so assuming your “main” network leads to the internet, then that is what you connect both App and ESP too.

How can i know what is the firmware needed?
And where can i get it?
Actually when i flashed the firmware the esp apeare on my phone.
I believe there must be an internet to connect to server.
But in this case i don’t know why the blynk still offline.
Do you think it’s wrong firmware( it’sAT22SDK100-2015-03-20-boot1.2.bin )? Or the dip pins on wrong situation when uploading esp shield example

In what way does it “appear” on your phone? Under WiFi connections detected?

Also… exactly what shield do you have? Do you have a link to where you got it?

I am using this board

And i select on the arduino ide espduino board to upload to esp

OK, I remember now, I get lulled by generic user icons :stuck_out_tongue_winking_eye:

Not sure why you opened a new thread as the issue is the same as before. I don’t think anyone else here has that board yet… so I am afraid you will have to keep working with the DIP pin info, others have already found for you, and fall back onto trial and error.

However, I remind you, you cannot link that board to your app directly… the board needs to communicate with a server, either Cloud (over the internet) or you can install a Local Server on your PC (if not on an RPI or other similar board that can run Java).

I am trying to connect the arduino robot dyn to blynk through esp8266 wifi shield example.
I am already got the esp8266 which built in the robot dyn board on my blynk app(online), but just by choosing esp8266 device on the app, and by uploading esp standalone example and by choosing olimex MOD -WIFI-esp8266 board.
I want to connect the arduino and i set esp-atmega
But arduino device still offline, just the esp is online.
I think this board maybe doesn’t have blynk example.
And maybe doesn’t have a device on blynk app.
Please let me know if you know exactly which device, board, example should i use to make it online.

i do not really understand what you mean by this. how it is the arduino supposed to be online?
isn’t it uses the esp for connection?

also, you can try “generic board” in the hardware list. maybe will work…

btw, what server are you using? cloud or local?

@bhaa The Mega 2560 option will work best in the hardware choice (in the app) as that will exactly match the pinouts. And probably ESP8266 & WiFi (for any example sketches in the >example browser<) to include the required libraries.

I configured the pins to set usp to esp mode and
The only example which uploaded is standalone esp shield and after uploading the esp is apear as online,
I am using cloud server.

At what mode should i program the esp in order to
Make the wifi connection with the arduino.
Should it be client or just to flash it with the frameware.
And how can i get the exact frameware?
I already tried all the choices. And today is the first time the board online but not as requested.

i see. but if the esp is online in the app, what is the problem?
try to use the board type what @Gunner recommends in the previous post, and you’re done.

eventually, you can test the system with a very simple uptime sketch, like this:
(of course, add your own library and blynk settings to this sketch). create a simple display widget in the app, set to virtual pin 0, and push. you should see the seconds increment.

#include <SimpleTimer.h>
SimpleTimer timer;

void setup()
  timer.setInterval(1000L, uptime);

void loop()

void uptime()
  Blynk.virtualWrite(V0, millis() / 1000);

The esp is online. But the board i have is robot dyn
Which have esp8266 built in shield.
But the issue is the arduino still offline
What ever you do

So do you mean the esp must be online
But that doesn’t give the correct pinout of my board

hm, did you choose mega2560 in boards list in app settings?
also, it would be nice to copy paste your exact sketch what you have currently on the board…

in the app:

now, copy your sketch here

1 Like

i used the standalone esp8266 shield example
and i gave it the auth and ssid and pass
and uploade it to esp
then it done and i connect to esp through my blynk app by using esp8266 device.

then i changed the pin mode to ( usp<> atmega2560<> esp) , and i changed the board to arduino
mega 2560, and uploaded the esp8266 wifi shield example from blynk- boards wifi - esp8266 shield.
and it done, but when i changed the device to arduino mega on my blynk app it become offline.

what do you think is the problem?
is there a specific code for my board and not exist in examples? or the same example but need edition?

i do not know, maybe it should be a specific sketch, but if you do not mind to share your exact sketch here on the forum, i can not verify…

if i were you, i would check all the described dip switch modes on the aliexpress description, maybe you are trying a wrong combination. reading the description on the aliexpress site, it is not very clear to me which mode should be used… maybe this one: ATmega2560<->ESP8266, after you uploaded the sketch…

next time, before buying, you should check what support and documentation the respective board has on the internet. because this board is probably very rare, and very few people know how to use… unfortunately it is not easy to help.

you should look into “official” arduino clones or wemos, etc boards.

Actually today and finally i got the board online on my blynk.
I used arduino wifi example. And i will provide it to you.
But actually we have a final problem and maybe it’s simple or related to code. The problem is the pins doesn’t respond to blynk. I am using bottun wedget
And i tried to select many pins on the board without respond despite the board is online.
Have you ever face such these issue?