WidgetTerminal \t prosessing

Всем добрый день
Widget terminal processing sign \t is very strange, if you put one \t there is no space at all. And if you put three in a row it puts 2 spaces that are not tied to the line. Is that normal behaivior?

terminal.print(String("")+ "CPUt:" + cputemp + "°C" + "\t");
terminal.println(String("")+ "GPUt:"+ PCdata[1] + "°C" + "\t\t\t" + "SSD:"+ PCdata[3] + "°C");

Yes… it is a form of character control \t is tab, others such as \n is a new line and \r is a carriage return. Thus if you actually want to print a backslash, you need to do it twice.

@Gunner I don’t think @777 want’s to print a tab.

@777 I think if you were using Blynk.virtualWrite() to send the String to the terminal it would work. Are you calling the terminal.flush() somewhere in your code?

yes i call flush at the end

For debugging purposes try VW.

Actually I have no idea what the issue was… I was just pointing out that you can’t just print a single backslash… in case that is what the OP was trying to do with all those backslashes

Eg. if you want to print "\ This is a backslash" you need to actually print "\\ This is a backslash"

1 Like

i want just tab space like in word document :grinning: if this is possible

I don’t think the terminal widget follows all the conventional character commands… you might just have to print hard spaces :stuck_out_tongue:

i got same result with VW, \t just dont work as it should

777, im not suggesting this is a fix…but im curious what this code would do.

terminal.print(String("")+ “CPUt:” + cputemp + “°C”);
terminal.println(String("")+ “GPUt:”+ PCdata[1] + “°C” + “\t\t\t” + “SSD:”+ PCdata[3] + “°C”);

Looks like escape t (tab) is not implemented for terminal (in either syntax).

same result, nothing