BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Why blynk.air is not shiping. showing Firmware type mistake


I am not able to give OTA update to my esp8266. When i give start shiping, within a sec it shows Firmware type mistake. also, i checked all the parameters like tempt id and device name. in edgent code I just changed the firmware version from 0.1.0 to 0.1.12, remains i didn’t touch anything, also i tried with new templet. even with new blynk account this problem is coming again and again. should I need to change the board.
kindly help me to solve these issues!!!

1 Like

also, Iam having the same issues, is there is any techy to solve this or find the reason for the issue.

When you go to the Blynk.Air screen and create a new shipment, are you choosing the correct template then choosing the correct device?

What happens if you choose “no condition” in the “Apply update if this device has…” drop down box?

What happens if you change your new firmware version number to “1.1.2” rather than “1.1.12” then recompiling and exporting the binary file?

Pete.

I think maybe you don’t use the ESP board versision 3.x.x.

Or you change your new firmware version number, the increment numbering is incorrect. Example: “1.1.1” to “1.1.5”
Should be: “1.1.1” to “1.1.2” ; or “1.1.1” to “1.2.0”

Or, we must wait about 45m for the next shipping/

And now, i think the reason is “you use the same code for the shipping”, i should edit something for make the differrent file size.

This error means your Template Id on the device doesn’t match the uploaded firmware template id.

This check was done specifically to avoid errors when you upload the wrong firmware for the wrong device (we saw it in the wild in the past). In other words - the current OTA doesn’t allow you to change the tempalte id during OTA.

However, I agree that we can improve the message, as it is outdated already. I’ll create internal ticket for the imporvement.

2 Likes

Solved here.