BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Where have I gone wrong?

I’m sure before now this was working fine, but now when I ask my local server to email me an export of a trend, I get a link to my email as http://127.0.1.1:8080/***. Stars being the directory to the csv file. If I replace localhost IP with my Pi static IP, my links works a treat…But how and where is there a setting to tell blynk server to use a specific static IP for its email links?

Hi, if I understand your question you have problems when your local blynk server need to send an email.
Blynk server, in order to send email will use the mail.properties configuration file. Following an example: (please note that I use Gmail):

mail.smtp.auth=true
mail.smtp.starttls.enable=true
mail.smtp.host=smtp.gmail.com
mail.smtp.port=587
mail.smtp.username=<mail>@gmail.com
mail.smtp.password=*************
mail.smtp.connectiontimeout=30000
mail.smtp.timeout=120000

Hi thanks for the reply. Maybe I wasn’t super clear. I have email setup and working really well. Only when the email comes through, the link I use to download the csv file is made up of this 127 ip rather than my local static server IP. And because of this when I click on it nothing happens until I modify the URL in the browser to reflect my server IP. Does this make sense?

Solved myself by using server.host= in server.properties

2 Likes