BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Wemos D1 Mini error: espcomm_upload_mem failed

esp8266
#1

Arduino: 1.8.9 (Windows 10), Board: “WeMos D1 R2 & mini, 80 MHz, 9600, 4M (3M SPIFFS)”

Build options changed, rebuilding all
Sketch uses 222197 bytes (21%) of program storage space. Maximum is 1044464 bytes.
Global variables use 31572 bytes (38%) of dynamic memory, leaving 50348 bytes for local variables. Maximum is 81920 bytes.
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

0 Likes

#2

These sort of upload errors are quite common (for me at least).

Start by ensuring that there’s nothing attached to your Wemos other than the USB cable.

My process is usually…

  • Check that I’ve selected the correct COM port
  • Try uploading again
  • Disconnect and re-connect the Wemos and try again
  • Disconnect the Wemos, press and hold the reset button on the Wemos whilst re-applying power (this prevents any current code from running when the Wemos boots), then try uploading again
  • Close and re-open the Arduino IDE and try again.
  • Reboot the PC and try again.

I’ve never had a situation where one of these steps hasn’t fixed the problem for me.

Pete.

2 Likes

#3

I tried your options. It could not be solved yet.

0 Likes

#4

I have the same issue with one of my Nodemcu
CH340 chip is corrupt
it never works, I got refund from Chinese seller :rofl:

0 Likes

#5

you can try that , maybe you’ll be lucky

0 Likes

#6

I think so it might be corrupt.

2 Likes

#7

Maybe you can use RX TX to upload the sketch , but you need usb/serial module?
is it worth it ?

0 Likes