BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Web Dashboard Widget Not Working

[EDIT] Solved my own problem… You have to go Devices. THEN Dashboard. Leaving this here incase it helps someone else. [SOLVED]

After spending much of the day I have a Sparkfun ThingPlus32 board running the new Blynk 2.0. In the web dashboard I can only add a switch to turn an LED on and off. On the phone I can add a button on the mobile dashboard.

The button on the mobile dashboard works and will turn the LED on and off. But not the switch on the Web dashboard. Same Template and same Virtul Pin, Data stream etc.

1 Like

Do you have iOs or Android? What app version? Does app changes it state when you change the state on the web?

Actually I have both Android and Apple. It did the same thing on both. I have since scrapped it all and started over. Now the switch will work on the web dashboard. Hopefully soon there will be a momentary button option. That is what I really need and its working on the phone as a “Page”. When it is set as a “button” it behaves like an on/off switch and not a momentary button.

Also, the button triggers a relay which turns on a small water pump. After about 10 seconds the board looses connection with the cloud. It’s only doing that with the momentary button. If I use the Switch widget, I can turn it on and will stay on forever and the board stays online. That’s not good though because the pump fills a small water reservoir and will overflow so I use the momentary button.

THANK YOU!

I Had exactly the same problem. Your workaround-solution worked!