BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

"Wasn't online yet" error on Mac Pro

Hi everyone, I’m having problems to connect my ESP8266 to Blynk server . I’m fallowing every steps required, I really appreciate your help in advance.
First of all, I’m using Mac Pro and ESP8266 which is connected to USB port trough the usb converter. and it shows usb port is connected perfectly . so with that part all good I guess.
secondly I’ve chosen generic ESP8266 Module from the board manager.
And also speed is on 115200.
I’ve already done java setup and now I am connected to Blynk app through the admin username and password that I received on terminal monitor, after server setup is completed.also My mac Firewall is off.
Now, here is my code and serial monitor:

#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "8vmlStF-rQFWpxPjAUTrWa7ir7f6e_uw";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "WiFi-V6C1-6G";
char pass[] = "148895555";
char server[] = "192.168.1.101";
void setup()
{
  // Debug console
  Serial.begin(115200);

  Blynk.begin(auth, ssid, pass,server);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
// Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,103),8080);
}

void loop()
{
  Blynk.run();
}

serial monitor seems wried because when I press the RST bottom it shows:
sd$⸮⸮|⸮l⸮<⸮l⸮c|⸮⸮⸮⸮r⸮#⸮c⸮⸮go⸮dog⸮⸮⸮cpćdsdrl8⸮o⸮⸮$⸮⸮b‘⸮|⸮l⸮⸮c⸮⸮o’⸮l⸮⸮d⸮egndags⸮ۓn#$;⸮⸮gcl⸮c⸮⸮$s⸮`⸮⸮n⸮[67] Connecting to WiFi-A5C1-5G
I also tried with Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,103),8080); and didn’t work.
is there any steps that I’m missing?

Thanks - Sani

Here is what I get on my serial monitor.

Thanks - sani

@Sani please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:
```
Copy and paste these characters if you can’t find the correct character on your keyboard.

Pete.

1 Like

These characters:

are the boot-up message from the board.
They look like this because the board is outputting the messages at 74880 baud, and you have your serial monitor set to 115200 baud.

If you change this line:

to 74880 and set your serial monitor to the same rate then you will see both the messages from the board and the debug serial messages correctly.

This messaage:

tells you that the board is trying to connect to your WiFi, and as this is the last message that you see, that connection is not successful.

ESP8266’s only support 2.4GHz WiFi networks, so start by ensuring that the credential you’ve supplied are in fact for a 2.4GHz network.

Both ssid and WiFi password are case sensitive, so ensure that they are both correct.

Pete.

Thank you Peter.
after switching to 2.4GHZ network I’ve now getting new information on my serial monitor.

as you could see it keep saying (Connecting to 192.168.1.101) and when I press the RST bottom its showing that the server is connected to “192.168.1.103” which is not me and it continues again.
after I looked to my previous message I have mentioned 192.168.1.103 as a server by mistake and now I corrected.
Just wondering how come its connected to the wrong server number ? and how I can resolve this issue please ?

here is my code again


#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "zat4KJ8KE85jZxm_kN5bJfelVIx_RlmE";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "WiFi-A5B1";
char pass[] = "****";
//char server[] = "192.168.1.101";
void setup()
{
  // Debug console
  Serial.begin(74880);

  //Blynk.begin(auth, ssid, pass,server);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,101));
}

void loop()
{
  Blynk.run();
}

So, you’re running your own Blynk local server, and using Blynk library version 1.0.0-beta.3
Both useful pieces of information which ought to have been included in your first post, along with which local server version you are running.

First of all, uninstall the beta library and install 0.6.1 instead.

Second, specify which port to use when connecting to your local server:

Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,101),8080);

This is assuming that you haven’t specified a different port when you created your server

Third, check that your local server is running, and what the logs say.

Also, it’s far better of you copy and paste your serial output, rather than posting screenshots.

Pete.

Thank you for the info. Now its connected and that error is gone after adding 8080.
and now my serial monitor is shown as below :

rld⸮⸮|⸮l⸮|⸮l⸮c|⸮⸮⸮⸮;⸮c⸮c⸮⸮gn⸮dog⸮⸮⸮c8⸮⸮lrd;lx⸮o⸮[4919] Connected to WiFi
[4919] IP: 192.168.1.103
[4919]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v1.0.0-beta.3 on ESP8266

[4926] Connecting to 192.168.1.101
[5010]⸮

but I still can’t figure out why its saying that is connected to different IP: 192.168.1.103 , however now its online but the test is not working as I’m trying to just turn on the led builtin of my ESP8266 as a test.

is that because I’m still running it trough beta library? And how should I really remove that library ? and when I select 0.6.1 on library manger nothing comes up.

Thanks - sani

That’s what you’re telling it to do. You are telling the Blynk library that you have a Blynk local server running at IP address 192.168.1.101

192.168.1.103 is the IP address allocated to your board via DHCP

Pete.

I understand but I don’t . here is my server details below, I don’t have any idea with the IP address 192.168.1.103 and I don’t know where is coming from!!

Last login: Tue May 4 16:13:10 on ttys001

The default interactive shell is now zsh.

To update your account to use zsh, please run chsh -s /bin/zsh.

For more details, please visit https://support.apple.com/kb/HT208050.

192-168-1-101:~ vahidsani$ java -version

java version “1.8.0_281”

Java™ SE Runtime Environment (build 1.8.0_281-b09)

192-168-1-101:Blynk vahidsani$ java -jar server-0.41.15-java8.jar -dataFolder data_server

Blynk Server 0.41.16-SNAPSHOT successfully started.

All server output is stored in folder ‘/Users/vahidsani/Documents/Blynk/logs’ file.

Admin password not specified. Random password generated.

Your Admin url is https://192.168.1.101:9443/admin

Your Admin login email is admin@blynk.cc

Should I remove Blynk library and install again?

Thanks -sani

Pete.

I deleted library folder and rest my system and then downloaded the zip file from https://downloads.arduino.cc/libraries/github.com/blynkkk/Blynk-0.6.0.zip and added to my library.
from library > blynk > wifi board > and selecting on NODMCU sketch. Behind my board its saying use 9600bps bud rate so I’m fallowing the same instruction.
Now my app still remains connected to the server but I still can’t have access to LED builtin on my board as when I touch the ON bottom nothing appears on my board.
And also my serial Monitor remains the same with unreadable text till I press RST bottom BlYNK logo appears. here is my code and serial monitor in below:


char ssid[] = "WiFi-A2C1";
char pass[] = "****";

void setup()
{
  // Debug console
  Serial.begin(9600);

  //Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
  Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,101), 8080);
}

void loop()
{
  Blynk.run();
}

2dO,4`llE⸮4C&>[67] Connecting to WiFi-A2C1
[1071] Connected to WiFi
[1071] IP: 192.168.1.103
[1071]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__

Am I fallowing the instruction correctly?

Thanks - Sani

Since my app is connected to the local server respectively which is shown Onlin in the app , do you think the reason I can’t have access to my board is coming from my local server or could be something else?

Appreciate your help.

Sani

Thanks -sani

Clearly not!

In the Arduino IDE, go to Sketch > Include Library > Manage Libraries…
Type “Blynk” in the search box, choose version 0.6.1 and Install

I’ve already explained why it’s better to use 74880 as your baud rate in this situation.

Your first post said you were using an ESP8266 + converter, now you say that you’re using a NodeMCU. From what you’ve said about the writing on the back, I’m guessing that it’s a Lolin NodeMCU V3. If that’s the case you should select NodeMCU 1.0 or higher as your board type.

Are you able to log-in to the admin console of your server?
How did you obtain the Auth token that you’re using?
What does your server log show?

Pete.

I was not able to choose the exact version as your instruction so I proceeded it with zip file and now its added in my library.

Yes I am using ESP8266 as its written on front of my board and on the other side of my board its written new NodeMcu V3. So that’s why I’m choosing NodeMcu sketch from library, but I have doubt if that appropriate or not?

Yes , I login to Blynk app with admin username and the Password of my server and it goes well.

Once I create a new project so then i collect the Auth Token from the screen and copy and paste into the sketch.

18:59:53.693 INFO - admin@blynk.cc hardware joined.
19:00:03.212 INFO - admin@blynk.cc Blynk-app (iOS-22606) joined.
19:13:28.231 INFO - admin@blynk.cc Blynk-app (iOS-22606) joined.

one thing id like to highlight is , " hardware joined" appears when I click the RST bottom, and as I explained before Blynk logo appears on my serial monitor at the same time.Because on many tutorial I watched ,after sketch is uploaded that Blynk logo appears on serial monitor automatically. is that a sign that telling me something is going wrong or that’s normal?

Thanks for your help .

Sani

Your board is a NodeMCU. Use NodeMCU examples, and select NodeMCU v1.0 or higher as your board type when you compile the sketch.
Choosing Generic ESP8266 as your board type will cause errors with any sketch which attempts to refer to GPIO pins using their “D” numbers.

It’s the information that appears after the Blynk logo which is important. You should see a “connected” and a ping time, and the app will show the device as online.

Which pin is your button widget connected to, and what board type did you choose in the app?

Pete.

I have now tried NodeMcu 1.0(ESP.12E Module )

I have now this info on my serial monitor and app is showing device is online ,which seems to be right I guess?

s$lܟ<⸮l⸮|⸮l⸮#|⸮⸮⸮⸮s⸮b⸮c⸮⸮‘o⸮$g’⸮⸮⸮cp⸮⸮ds$sdp⸮g⸮[5916] Connected to WiFi
[5916] IP: 192.168.1.103
[5916]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v0.6.1 on NodeMCU

[5926] Connecting to 192.168.1.101
[5990] Ready (ping: 10ms).

22:29:37.315 INFO - admin@blynk.cc hardware joined.
22:32:37.130 INFO - admin@blynk.cc Blynk-app (iOS-22606) joined.

I’ve now chosen NodeMcu and pin D0. am I fallowing the steps correctly?

Thanks again.

sani

So, you have successfully connected your NodeMCU to your local server. The device should show as being online in the app.

The onboard LED on the NodeMCU is connected to GPIO2, which is the pin labelled D4.

I never use digital pins in the Blynk app, but I’d suggest that you either need to choose D2 or D4 in the app if you wish to control the onboard LED with a widget.

Pete.

Amazing … its working . Thank you so much sir !!!

1 Like