BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

VPS Disconnect Problem

Hi Blynker

I found that my local server disconnects after some time, every time I need to give the command as shown in the attached picture, how can we solve this problem? Thank you very much for the attention .

on your picture, your local server is running well.

1 Like

ahh you meant blynk process getting terminated!

Do you have enough ram in the VPS?

Yes it works fine because every hour the server disconnects and I have to enter the start command.

Yes my 1Gb VPS has always worked correctly from one year to now, two days ago with the launch of the new Blynk platform it seems the problems have started. In fact he disconnects after an hour and I have to run the command to start the server, it doesn’t always remain active.

are you by any chance running that command over ssh terminal? or VNC?

That execute command sends it via SSH.

1 Like

That’s the issue! When in your phone the application goes in background and the SSH session ends the process too ends with it!

Add that command in system startup or use screen to create a virtual screen and run in that! If you need help you can DM me!

Yes, you are perfectly right, what you described happens. Yes I need help, if you can kindly help me fix this problem so you don’t have any more problems. If you want we can feel private. Thank you so much !!!

Follow this! use the crontab approach !
After adding that line to cron reboot!

Whenever you close the terminal blynk process is stopping. To stop that happening you need run the blynk (java) process in background. To do that, you need to setup crontab.

Here I written article about it: Installing Blynk Server on Ubuntu Cloud Server [Digital Ocean VPS]

The above tutorial will work for ubuntu apache server.

1 Like

Excellent Great Guide, unfortunately I didn’t realize the VPS server because I wasn’t able, a type that unfortunately no longer exists. Now I’m not very able to fix it. In the photo I tried to give some command but it seems to not work. If it’s not a problem for you if you help me fix it in an instant. Just write to my email. (dlamattattina@mail.ru). Thank you so much .

Firstly its crontab -e not contrab
Second, its "java - jar location where our blynk server file is.jar "

no need to specify data folder

Looks like you are also using ubuntu server so my guide should work if you followed that tutorial correctly.

I can clearly see in your screenshot that you are entering crontab command syntax in a wrong way.

You entered: crontrab -e

Instead of: crontab -e

(Did you notice you added extra “r” in the command?)

Based on this screenshot: https://community.blynk.cc/uploads/default/original/3X/e/9/e90cf088be3ec127ff029b853af38214f1beacb2.png

I’m assuming you downloaded blynk jar file in your root directory. Based on that I’m giving below command.

First enter:

crontab -e

then paste the below in the crontab terminal.

@reboot java -jar /root/server-0.41.6-java8.jar -dataFolder /home/pi/Blynk &

NOTE: Make sure you enter full path to *.jar file. In the above example I’m assuming jar file can be accessed here: /root/server-0.41.6-java8.jar

After that reboot the server.

sudo reboot
1 Like


Here is the command I gave, but now what should I do ?

put the below command after the last line. (that is, after this line # m h dom mon dow command)

@reboot java -jar /root/server-0.41.6-java8.jar -dataFolder /home/pi/Blynk &

NOTE: Make sure you enter full path to *.jar file. In the above example I’m assuming jar file can be accessed here: /root/server-0.41.6-java8.jar

After that reboot the server.

sudo reboot

Screen is easier to use if you are beginner. Install screen (Sudo apt-get install screen) and then open screen… type command to run blynk server and disconnect screen. That’s it.


I put the command but it seems to be working nothing.


I put the command ticked this.

sudo reboot

command should not be placed in cron terminal. It should be executed outside the crontab. Remove that command.