Virtual Pins with v2.5.10 update

Since the latest update to Blynk v2.5.10 I had two separate issues with virtual pins on two different projects.

The first project uses a Wemos Mini D1 and is used to control my garage door. I also have a virtual LED showing the state of the door. After the update, I was not able to open/close the door. I connected my laptop to the board and opened serial monitor. I did not see a button push when I was pressing the button widget assigned to V1 in my project. I loaded the project on a brand new Wemos and got the same results. I then changed the code and re-assigned the push button widget to V10. The door started working correctly again and I was able to see the button push in my serial monitor. I then re-assigned the push button widget and changed the code back to V1. Now it works fine, on both boards! This project has been running for over 6 months without issue. The only changes made to it was the latest update.

The second project is using a Particle Electron. I am in the middle of building a project. I have two button widgets, one assigned to V0 and one to V3. During my testing and after the update, all of a sudden V0 and V3 did not function. I re-assigned the widgets to open virtual pins and the sketch started functioning correctly again. After that I re-assigned them back to the original settings of V0 and V3 and they worked correctly.

I have no clue why they stopped and then worked correctly again after switching them to a new pin and then back to the old. I am using iOS v9.1 on and iPhone 6 with Blynk app version v2.5.10 updated on December 13 and library version 0.4.1 in the Arduino IDE. I do not know what version the Particle IDE is using for Blynk library.

I did a search on the forum and I did not find anyone else reporting this issue?


Thank you for detailed explanation. It could be related to recent button changes (it now can send not only HIGH/LOW). However we did huge list of updates recently so right now it is hard to say what was that exactly. What version did you have before?
@eugene any thoughts?

You are welcome. Thanks for your reply. If you are asking which version of the Blynk app I had before? There were two recent updates to the iOS app. The one I mentioned and one a few days prior. I usually do the app update as soon as it is released. Everything worked well until the latest one. I have been working daily on the Electron project so at first I thought I had an issue with my code after making some changes. I really connected the dots when I moved my plow truck up to the house from the barn last night and was not able to open the door with my phone.

@mpo881 Thanks for your report. Few questions:
Do you remember if the pin assignment were lost when you opened widget settings for the first time after update? Or was it present, just not functioning.
Was this issue only with buttons or did you have to reassign pins in other type widgets?
Also, do you use our app on your iPhone only (and no other devices like Android)?

@eugene I am not sure I understand your question.

However, in the case of the Wemos board, I opened the app and pressed the button widget assigned to V1 and nothing happened. I also have a Notification widget, two LED widgets and a timer widget. When the app failed to open the door, I pressed the wall button and the door opened and the LED widgets updated (one shows open, the other closed and they read the state of a magnetic switch). So, I disconnected the hardware from the door opener, brought it inside and re-loaded the software. I then re-installed the hardware and tried to open the door without success. At that point, I remembered the issue I had with my other project, so I changed the code from V1 to V10 and also changed the assignment in the app. I loaded the updated sketch and the app was able to control the door again. I then went back and changed the code to V1 and the pin assignment on the app and then it worked with V1 again.

With the Electron project I was doing some testing so I was changing code around, loading it and testing it. I had some issues and left it sit overnight. The next morning when I woke up there was an update so I allowed the update. Then when I started up my electron to re-test the last code, I noticed V0 and V3 button widgets were not doing anything. So, I did the same thing, I reassigned both new pins, V10 and V11. I reloaded the exact same sketch with only those changes and everything worked. Then I changed them back to V0 and V3 and they still worked.

I have only had to do this once on both devices. Once I switched them and then switched them back, they are continuing to work at this point.

As far as I can tell, yes. The wemos is only using 1 button widget, 2 LED widgets, a timer widget and notification widget. As stated earlier, the LED widgets were updating when the state of the mag switch changed. The timer was active so the widget was flashing.
The Electron project uses 6 button widgets, a notification widget and two value widgets. So, not much to tell you here except that V0 and V3 when pressed did nothing until I performed the changes outlined above.

The projects do exist under my credentials on an Android device, Galaxy. I do not have the phone in front of me so I would have to get the specifics to you later.However, the Wemos project has only been operated very rarely and the Electron project has never been operated from the Android. I did do a Blynk update on that device around the same time too so I could check out the new GPS widget.

Let me know if you need anything else.


@eugene[quote=“eugene, post:4, topic:10115”]
Do you remember if the pin assignment were lost when you opened widget settings for the first time after update? Or was it present, just not functioning.

I read this question numerous times, it finally sunk in! My apologies. The answer is that the pin assignments were never lost, they just were not functioning.


This is nearly identical to my experience within the past couple of days as well, though with a NodeMCU 1.0 (12E ESP8266 module).

@josecanuc thanks for the reply. It looks like there are a few posts with similar problems. Blynk team is on it!

Thanks guys, I now have clear picture of what happened and working on it.

Also, please remember to not use both Android and iOS on the same project for now. Currently Android saves project in the new format (with support of many devices) which is not fully compatible with old format. iOS will catch up soon!

1 Like

Thanks for getting on this so quickly. [quote=“eugene, post:9, topic:10115”]
iOS will catch up soon!

That would be great. It would be nice to see the iOS side take the lead for once too! :grin: