Video streaming (rtsp) not working on my Nexus 6 Android 7

I’m an happy user of blynk and I’m working on my plant water feeder :slight_smile: I’ve a camera (hikvision) and I would like to add a video on the blynk app, unfortunately I can’t see the stream. I tried to connect both from internal LAN and from internet but with no success. I’m acctually using as URL rtsp://:554, I tried also rtsp://:554/h264/ch1/sub/av_stream ma no result. I can instead view other streaming but using http://xxx url.
Thank you for the help


@almoondsllc are you using the very latest libraries and apps?
Blynk introduced an rtsp bug recently but it was promptly fixed.

1 Like

I’m using 1.16.6 version on my phone

The bug fix was included in 1.16.5 so you should be good to go.

can you make a try with this link: rtsp:// ? thank you

Tested as working with 1.16.5. and 1.16.6.
It takes a little over 10s for the video to start streaming.
Have you tried the url with VLC or similar, works with VLC on my Android (Samsung S3) and on my desktop (Win 8.1)?

I also tested the link from a PC with VLC and from an Android with VLC and it works, so the RTSP link is ok but…It doesn’t work from Blynk (I have Nexus 6 with Android 7) with the video streaming widget. So can someone confirm that the widget works with rtsp link? Thank you

Must be an Android 7 problem. Do you have any other Android devices to test the url with?

It’s not android 7…it’s my Nexus. My friend has Android 7.1 and it works.
So it’s my Nexus 6 + Android 7. Also with the last version of Blynk I got “no video stream available” :((

@almoondsllc is there much difference between 7.0 and 7.1?

Probably specific to your Nexus / network / firewall.

@almoondsllc I tried your link on my own Nexus 6 ver.7.0, also with no results; However, my Samsung Note8 ver.4.4.2 was able to play the stream just fine (I also had it running in VLC on my PC at the time, and got lots of loud bells ringing in stereo :grinning: )

I was however able to get this test video working on both (sorry for long URL… just something I found on the web):


I also noticed that the “newer” device, Nexus 7, also displayed the wrong text colours and formatting (any colour you want as long as it is white :confused: )… Perhaps something about the different Android versions that is also related to the video issue?

EDIT 12/28/16 - The text issue was due to inadvertently having High Contrast enabled on my phone (my bad)… but no video is still an issue.

And finally (must sleep sometime), I also tried both video streams on an old Nexus 4 phone ver 5.1.1.

rtsp:// - Did NOT work

rtsp:// - DID work, however repetitively caused a “reconnect to server” every few seconds.

Hope this all helps, and sorry if I am incorrectly intruding in this post.

First of all thank you for your test and I don’t think you’re “incorrectly intruding in this post” :slight_smile:
So I confirm there is a problem with Nexus 6 / Android 7, it’s not only my case.
Of course I’m ready to change the phoine just to see Blynk working :))

1 Like

@almoondsllc No problem, I want to get video working as well… but I have not yet had much “Blynkin” :wink: success on any of my Android devices, at least with the various IP cameras/streams that I have.

But I am not ready to toss out the old Nexus 6 yet, as I also use another robot control app that DOES work with the IP cameras/streams that I have - BT Bot Control Pro - in which the camera view seems more like an embedded web browser; However, it DOES NOT directly support RTSP… some days I just can’t win.

Perhaps if they offer both web based and stream based widgets to support the masses (he says like he knows what he is talking about :confused:).

EDIT - I have just tested RTSP Camera Server using a Nexus 4 as the “IP Camera”.

It worked fine in Blynk on my Samung Note 8 (ver.4.4.2) but NOT on my Nexus 6 (ver.7.0)… so there apparently is some tweaking needed for video compatibility with Android 7.0?

If anyone has a video stream that will not play on their Smartphone could you perhaps provide the full codec details as advised by VLC. There should be a video stream (e.g. H264 MPEG-4 AVC (part 10)) and an audio stream (e.g. PCM ALAW).

Also provide Smartphone make, model and Android version.

I have given up with video issues in Blynk for now… “they’re so naughty and so complex”… but since you asked :smiley:

It took me awhile to figure out what you were asking for and where to find it (I have only ever used VLC it to watch “borrowed” :wink: movies), but here we go…

PHONE: Nexus 6 (ver.7.0)
STREAM: rtsp://

1 Like

@Gunner thanks but I already have the codec details for @almoondsllc’s camera which generally works with Blynk.

I am looking for codecs that don’t work (or even that do) for other cameras that Blynk are using.

I made more progress last night. After tweaking some memory issues, one of the Samsung’s started “streaming”. The stream was actually a green screen and a bit of a video and then the video crashed. I think green screen is common when streams start and normally it clears but as the stream will only run for 5 to 10 seconds it doesn’t have time to clear.

I also noticed that the Alcatel that “works” only runs the video for around 50s and then it stops. 50s is ok for our requirement but would prefer continous streaming.

When I have time I will contact the manufacturer of my H264 and see if I can persuade them to move to an Android compatible audio stream. The audio stream they currently use can work with Android as demonstrated by the app they provide but it’s not native support. Alternatively they could just provide a configuration flag for end users to disable (not mute) the audio stream in their camera.

Failing that I’ll provide the details to @Dmitriy to see if he can add support for the audio stream at a future date. Not difficult for a super coder :slight_smile:

@Gunner could you please check if the “fastweb” url is still working on your Android. Sure it was fine for me when I last checked but today all i’m getting is audio and no video.

Seems to work fine on my Note8, but the video is in night vision mode.

Just a black screen with intermittent sound on my Nexus4.

And juggling dots on my Nexus6 (but then that is normal :slight_smile:)

1 Like