BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Using same blynk project on two different phones


#12

Just one thought, I was using the .us email address since first starting to use the app. I have never logged in with .com.

I will give it a try

Thanks


#13

Well, I am lost. I have spent a lot of time testing and trying to eliminate problems. Here is what I know. Prior to the last server upgrade I was able to connect to my project and Blynk worked well with it.

Since the upgrade, I have a difficult if not impossible time connecting. The hardware and sketch are the same. I have created a new Blynk account with a gmail address along with a new Blynk project and token.

I have tested my connection to the internet and it works well. I have tested my project and it sends me messages as it should when the conditions are met.

So, even though I show a good connection and I can receive messages from my project to my cell phone, I still cannot connect to my project via the Blynk app. It still says that my Arduino is offline.

Again, I did not re-write the sketch since testing of Blynk concluded. Was there an update to the Blynk library perhaps that I missed? Since the new server upgrade is there something that needs to be added to my sketch?

This is all very frustrating to have had it all working correctly and now it has all gone away.

Thanks

Brian


#14

@mpo881

Brian,

here is some bug exactly with your setup and your mails.
you are saying you are not using “gmx.com” but exactly it was updated today. “gmx.com” has 2 tokens:
first starts from “56eba”, second starts from “ff5a7”.
gmx.us” has no widgets in profile at all and has token start from “f3a18”.

Please check your code and tell me which one token you had uploaded to arduino.
Also try to logout, close app and login again. (In early versions there was a bug - login acc didn’t changed after logout, this is exactly what you could catch).

Please tell me your findings…


#15

Dmitriy,

Thank you for your reply. I have made some progress by using my gmail address. The token that I am using starts from “c66890”. I can now log in to either phone with those credentials and see my Blynk project. It still however keeps telling me the Arduino is not on line.

I have connected my laptop to the Cradlepoint and am clocking respectable speeds so I know that I have connection to the outside world. So, I have no idea why my Arduino is no longer connecting to the Blynk server? I can get messages from my project when the appropriate conditions are met.

Brian


#16

Has there been a change to the Blynk library in regards to the ethernet shield? I am using a Seed Studio ethernet shield V2.0 here;

http://www.seeedstudio.com/wiki/Ethernet_Shield_V2.0

When I try to compile my sketch with #include <EthernetV2_0.h>, which is what I have been using since testing began I cannot get my sketch to compile and get this error message;

Arduino: 1.6.0 (Windows XP), Board: “Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)”

In file included from C:\Documents and Settings\Brian\My Documents\Arduino\libraries\blynk-library-0.2.1/BlynkSimpleEthernet.h:14:0,
from Jackpot_V_1.9.2.ino:13:
C:\Documents and Settings\Brian\My Documents\Arduino\libraries\blynk-library-0.2.1/Adapters/BlynkEthernet.h:21:22: fatal error: Ethernet.h: No such file or directory
#include <Ethernet.h>

                  ^

compilation terminated.
Error compiling.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.

If I comment out #include <EthernetV2_0.h> and instead use #include <Ethernet.h> my sketch compiles correctly. However, I do not know if my project will connect to the internet with using Ethernet.h instead of EthernetV2_0.h. I will have to test it to find out.

Again, I have noticed these difficulties since the server was updated just prior to Blynk going live.

Thanks
Brian


#17

Sorry, we don’t support this shield yet. The list of supported hardware is here.
We are collecting information about what shields are more popular and implement them.

If you’re an experienced developer, you may look in the library code and hack your own shield integration.


#18

Huh? Well that makes absolutely no sense? This is the only shield that I have ever used INCLUDING as an early tester. Are you saying that now that you have gone live it will no longer work?

Please clarify

Thank you


#19

By the way, I forgot to add that it worked just fine during testing. Again, please clarify what you mean. If it worked before, it should still work unless there is something new in the new release or since you upgraded the server just prior to going live.


#20

Hey, I’m glad to hear that it worked…
By saying that it is not supported, I mean we do not test it to see if it works. So yes, something could break.
How can I know that it worked before? ) I didn’t understand you correctly.

Ok, let me check if I can get it compiling with this library. Are you using this one?
http://www.seeedstudio.com/wiki/File:W5200_Ethernet_Shield_Library.zip

Sorry for confusion.


#21

It is no worries. My reply was to be sure. If you found that zip file on the wiki link I sent you earlier then yes that is the correct file.

Thank’ you


#22

Well, I must report that I have had to remove Blynk from my project. :sob: Without being able to have the Arduino connect to the server, it caused so many problems that I was not able to run my project correctly. I have no clue what changed on the server end of things but I can assure you that my sketch and my hardware remain the same as they were during the initial testing when Blynk worked with my sketch and my hardware.

I really like the app so I am hoping you can find out what went wrong. When I remove the blynk code from my sketch my project works fine again.


#23

Just curious if we have made any progress?

Thanks much

Brian


#24

Yes, @mpo881.

I investigated the problem in details, and now I understand what happened.
Probably you were using IDE 1.0.6 before, and switched to 1.6.*
These versions handle libraries in a bit different ways, so you get the error (which is correct!).

Look, this shield uses its own library, and it is not integrated into Blynk yet. So please note, that changing the line:

#include <Ethernet.h>

into

#include <EthernetV2_0.h>

is not enough.

The reason “it worked”, as you say, may be in some level of compatibility between the chips (W5200 vs W5100).
In this case, try running with unmodified Ethernet example.
This will be exactly as it was during early testing.

Please tell us how it goes.


#25

Thank you very much. I will give it a try and let you know how it went.


#26

How did it go? Did you get it working?


#27

No I have not had any luck yet. I have made some changes to the code in an attempt to resolve it and it corrupts other parts of the code. If I remove all of the Blynk code, my sensors work as they should and message me when they should. When I add things back in, sensors and messages stop working.

I havent given up yet. It is somewhat frustrating because my project had worked with Blynk in the past. But, that is how it goes when you are trying new things.


#28

Does any simple Blynk example work with your HW setup (shield, etc)?


#29

I have given up on the other ether shield and have obtained an Arduino Ether shield with PoE. I did use the sample ether code from Blynk and was able to connect successfully.

I am now able to connect to my project and obtain sensor data. I have the sensors set to update via the Blynk app every 30 seconds which they are doing correctly.

I also have some switches that I am trying to get to work. As of right now, they do not work. I have tried to assign both virtual pins and the digital pins. No luck, Ill keep working. Any suggestions on the switch issue would be appreciated.

Brian


#30

FYI, I just timed it and it took ten minutes and 15 seconds to turn on a light using the same connection that is updating the sensor data every 30 seconds. Any ideas would be appreciated.

Thanks


#31

I ran another test on my project. I have 5 gauges that read battery levels. I disconnected one of the Bat V in connections on my PCB. The appropriate gauge on my touch screen dropped to zero while at the same time the value reading on the Blynk app read zero. I also received a text message that Battery 5 was low. So, you can see that this part works as expected. The Battery V in is connected via a voltage divider to A12 while the value display widget is assigned to V8 in the Blynk app.

None of my switches, which are assigned to digital pins on the Arduino and digital pins in the Blynk app work. I have defined a virtual pin map for Blynk in my Arduino code and have tried using Virtual pin assignments for the switches in Blynk that match the map in Arduino. Still nothing.

As a friendly reminder, this code did work during testing along with the ether shield that I have now replaced.

Thanks

Brian