Unable to verify example codes in Energia

Hello! I have used Blynk several months ago and I was able to get several simple things to work using my TI CC3200 board and the Energia IDE. However, I got busy and took a break from this hobby. I have a new project that I am now trying to solve and I am trying to use Blynk with my TI CC3200 board and Energia IDE. In trying to remember how it all works I am attempting to use the Blynk examples inside of Energia to blink an LED on the board on and off. However, every time I try to verify the code it gives me an error that I have never had before. I have tried updating the libraries, updating Energia, and even uninstalling and reinstalling Energia and I still have the same error. Any help will be appreciated!

The error message is pasted below:

Energia: 1.6.10E18 (Mac OS X), Board: "CC3200-LAUNCHXL (80MHz)"

In file included from /Users/timmills/Documents/Energia/libraries/Blynk/Adapters/BlynkWiFiCommon.h:19:0,
                 from /Users/timmills/Documents/Energia/libraries/Blynk/BlynkSimpleEnergiaWiFi.h:15,
                 from /Users/timmills/Documents/Energia/libraries/Blynk/BlynkSimpleTI_CC3200_LaunchXL.h:24,
                 from /Users/timmills/Documents/Energia/sketch_apr05a/sketch_apr05a.ino:51:
/Users/timmills/Documents/Energia/libraries/Blynk/Blynk/BlynkProtocol.h: In member function 'bool BlynkProtocol<Transp>::run(bool)':
/Users/timmills/Documents/Energia/libraries/Blynk/Blynk/BlynkProtocol.h:114:11: error: there are no arguments to 'yield' that depend on a template parameter, so a declaration of 'yield' must be available [-fpermissive]
/Users/timmills/Documents/Energia/libraries/Blynk/Blynk/BlynkProtocol.h:114:11: note: (if you use '-fpermissive', G++ will accept your code, but allowing the use of an undeclared name is deprecated)
/Users/timmills/Documents/Energia/libraries/Blynk/Blynk/BlynkProtocol.h: In member function 'bool BlynkProtocol<Transp>::processInput()':
/Users/timmills/Documents/Energia/libraries/Blynk/Blynk/BlynkProtocol.h:230:23: error: there are no arguments to 'yield' that depend on a template parameter, so a declaration of 'yield' must be available [-fpermissive]
/Users/timmills/Documents/Energia/libraries/Blynk/Blynk/BlynkProtocol.h: In instantiation of 'bool BlynkProtocol<Transp>::run(bool) [with Transp = BlynkArduinoClientGen<Client>]':
/Users/timmills/Documents/Energia/sketch_apr05a/sketch_apr05a.ino:65:13:   required from here
/Users/timmills/Documents/Energia/libraries/Blynk/Blynk/BlynkProtocol.h:114:11: error: 'yield' was not declared in this scope
exit status 1
Error compiling for board CC3200-LAUNCHXL (80MHz).

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

None of this appears to be a Blynk specific issue.

It looks like a possible syntax error in your code or the board is not configured correctly in the IDE.

Have you looked at >http://energia.nu/< and >http://forum.43oh.com/forum/125-energia-tivaccc3xxx/<

A lot has changed over the months with Blynk… There is also the added possibility that this Energia IDE is not using the latest Libraries - or outdated examples? You said you tried updating… but was the update successful?

Have you tried installing the core files for your board in Arduino IDE?

I think you have to remove this folder completely before updating the Blynk Library

Thank you both for your help! I removed the above folder as well as reinstalled Energia again and I believe I have fixed the issue I had with the Blynk Libraries. But I also magically made my Ethernet library as well as the CC3200 example disappear so It is hard to say for sure. I was able to get a Blynk example code to compile, so I believe I just need to try running with it now and see if I can find the other missing links. Thank you both again! I appreciate the help greatly.

1 Like