Unable to log into Admin page

@Dmitriy hello…
I am not sure weather i am in the right place to tell me problem, if am wrong sorry.

Basically i am trying create a Blynk Local server on my RPi3 (have done this before) . Following all the steps from github , downloaded the server server-0.32.2-java8.jar file , placed it inside a folder and used “Blynk $ java -jar server-0.32.2-java8.jar -dataFolder /home/pi/Blynk” … And this is giving me " Blynk Server 0.33.0-SNAPSHOT successfully started.
All server output is stored in folder ‘/home/pi/Blynk/logs’ file.
Your Admin login email is admin@blynk.cc
Your Admin password is admin "
I am unable to give my email id and password, even thought i have mail.properties in the same server folder. Tried many times, but not able to get it working. The output should say Blynk server started successfully , but mine its giving SNAPSHOT, dont know where am going wrong.
Help me Please

@Gunner am sorry . I guess i posted at a wrong place . Sorry for the trouble.

When the server starts it says SNAPSHOT ! What is it referring to ? Till now i tried the same procedure 8 times and out of 8 times i got “server started successfully” only twice , even though the procedure or steps was same. And also unable to login in Blynk app with custom server as the ip address is also not working and says port is open even though am not running anything out of it because os is just installed and am trying to create Blynk local server . It automatically takes the email address and pass as mentioned above.
Help me out.

Just means that it is a mid-release variation of the initial release version.

Depending on when you download the release version of the server, you will get either no SNAPSHOT or a variation of last uploaded SNAPSHOT.

If you are getting that far, then the server should be running. Whether is stays running when you close out that terminal is dependent on a few things like if/how you are automatically starting it or not, and what the command line you used looks like… did you add the & to the end?

mail.properties is not directly related to your administration account. The mail.properties is for setting up a SMTP process that the server can use to send out AUTH tokens and other data to the various users that sign up to your server.

The admin account is totally different… I have one but set it up a long time ago and rarely use it so I am not completely following what all you might be doing wrong with it. But at a guess, you need to create the admin login and password in the server.properties



Before it was working flawlessly with mail.properties . But this time its not working. As per your saying instead of creating mail.properties i have to create server.properties ? Will that work ? Because when i click email all from blynk app i have to receive the AUTH to my mail address right !?

What can be done to get it running !? I have tried all the possibilities to get it working.

Please give a link to create server.properties .
Thank you.

You need this anyhow… for your server settings, including the Admin page account

You still need this if you ever expect to get your Auth codes emailed to you… and CSV files, etc.

Same place you got the server files, directions, etc.


Please make time and watch this. I had followed this the previous time and got it working. But this time it is not working out. May be due to server update may be some procedures has changed. If possible Blynk team should make a video on this topic. Because no else can be as sure as Blynk team.

This was the clone from my previous Blynk server, and here is dont find any server.properties file. And this was working for me. This time am following the same procedure, but finding problems. :slightly_frowning_face::confounded::sweat:

Probably you was logging via http. Now you have to use https. http support for admin page was dropped.

now if i include server.properties along with mail.properties with my email and password in server.properties file will i be able to login from my blynk app ?

sudo apt-get update
sudo apt-get install fail2ban
sudo cp /etc/fail2ban/jail.conf /etc/fail2ban/jail.local

sudo apt-add-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java9-installer

wget "https://github.com/blynkkk/blynk-server/releases/download/v0.32.2/server-0.32.2.jar"


data.folder=./data logs.folder=./logs log.level=info enable.db=true admin.rootPath=/admin allowed.administrator.ips= server.host=xxx.blynk.cc contact.email=xxx@blynk.cc region=xxx


jdbc.url=jdbc:postgresql://xxx:5432/blynk?tcpKeepAlive=true&socketTimeout=150 user=test password=test connection.timeout.millis=30000 clean.reporting=false



IP Tables

sudo iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 8080
sudo iptables -t nat -A PREROUTING -p tcp --dport 443 -j REDIRECT --to-port 9443

sudo apt-get install iptables-persistent

sudo iptables -t nat -A PREROUTING -p tcp --dport 8442 -j REDIRECT --to-port 8080
iptables-save > /etc/iptables/rules.v4

I found this. Is this for RPi 3 ? or not ? what is to be filled with our credentials in server.properties file ?
Please guide me.