Unable to display sensor data on Blynk from RaspberryPi Grove Base Hat

Hi people,

I am trying to do a very simple temperature monitoring device using the Raspberry Pi 3B+, Grove base Hat, Grove Temperature sensor DHT11 and Grove 16x2 LCD display. The sensor and LCD display are connected to the Grove base hat via ports D5 and I2C .

I have managed to get the sensor data and display the readings on the LCD.
Using an Android phone, I have successfully linked the Blynk app to my RPi by following all the installation instructions.

However, I have tried all digital GPIO pin configurations and am unable to display the temperature data on the Blynk app.

Are there any additional library I need to import or modifications required to the python code below?

Thank you

import datetime
import time

from grove.grove_temperature_humidity_sensor import DHT
from grove.display.jhd1802 import JHD1802

def main():
    # Grove - 16x2 LCD(White on Blue) connected to I2C port
    lcd = JHD1802()

    # Grove - Temperature&Humidity Sensor connected to port D5
    sensor = DHT('11', 5)
    while True:
    #Grove HAT with external temperature sensor DHT11 and external LCD display#
        humi, temp1 = sensor.read()
        temp1 = round(temp1, 1)
        humi = round(humi, 1)

        print("Date & Time:", datetime.datetime.now())
        print("Temperature =", temp1, chr(176),"C") 
#        print("Humidity =", humi,"%") 

        lcd.setCursor(0, 0)
        lcd.write('Temperature: {0:1}C'.format(temp1))

        lcd.setCursor(1, 0)
        lcd.write(datetime.datetime.now().strftime('%d %b  %H:%M:%S'))

if __name__ == '__main__':

Please edit your post to add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:


Maybe this will help [SOLVED] Raspberry Pi 3 & Python (and NodeJS)

Hi guys,

Just to update…I tried to plug in the Grove DHT11 sensor directly into the GPIO pins VCC, GND and GPIO2 but the Blynk app only shows “HIGH” on the 'Labelled Value display". Is there something missing?

I tried a push button LED on the app and it works!

Did you change this…?


Set that to 0/1023 to see what kind of a number it is sending…

Problem solved.

Got it to work by adding a virtual pin to the sensor.

Good job :+1:t3: