TTGO T-Call ESP32 SIM800L cannot be connected with the Blynk cloud

Have you tried baud rate 9600 instead of 115200 ?

Hi John,

Yes I did…same result.

I’ve never bern able to get a T-Call to connect to Blynk using port 80, even with a variety of different SIM cards.


I would recommend esp32 or nodemcu boards instead.

It is an ESP32 board.


I know, I meant the one without sim card like the wroom and wrover etc.

Then you’d need to add an external SIM module. The T-Call is a nice elegant way to handle everything in one board, and has the advantage of having with a backup battery option too.


You’re absolutely right, I’m using an esp32 wroom and portable 4G router with a very high speed internet. With this method I can connect multiple devices to 1 router.

I agree Pete, the combination - ESP32 Sim combination is great for remote control, remote viewing, remote data applications. All inclusive - sim, wifi, bluetooth, external battery connection etc.

I will test code by adding, “”,8080

other than this I am not sure how to go about this project.

Is there anyway somebody could connect to my pc via teamviewer to assist with faultfinding?

That’s the Legacy URL.

IoT URL is “”


Noted, thank you Pete.

Can you believe this…still no success.

Who do you think I should contact to assist with debugging?

Best regards,

Have you tried a different SIM card?


Also have you tried

Blynk.begin(auth, modem, apn, user, pass)

I have used another sim card but will confirm if they have any restrictions. Blynk connected once and never again. Will keep you posted on the developments!

Thank you.

Hi John, I tested them all.

By the look of it, it must be hardware or sim card.

Code is in order.

Will let you know my findings.

Thank you for the guidance and assistance this far.

You’re welcome buddy

Dear Blynk Members,

Just to let you know – all in order and working fine every time.

After numerous attempts testing different sim cards from different network providers, I decided to purchase a global sim from “Justworx” with positive results.

My esp now connects every time to the Blynk Cloud without any issues.

Thank you for your input.

Best regards,

1 Like

I didn’t connect my TTGO for about a month. Now connection through GSM still works fine, but I can’t connect to through wifi again. Last time it took three days before it connected, without any change to code. Then it connected instantly for a while. Now the same code won’t connect again.

I tried the direct URL, but there I don’t even get a login timeout error.

Does anybody else get this behaviour from TTGO through wifi?