Trouble connecting my devices

Hi, I’m using Arduino and an ESP32 dev board. Right now I’m just trying to read the humidity value in the room and move the Blynk slider if the value is above 50. I encountered a strange issue. Suddenly no matter what I do my devices won’t connect. I finished a project earlier this week so i know for a fact that the code was working and my device was online. Then I started this project- new template, new device and suddenly I can’t connect any device. I tried it from a friend’s user and it worked twice, then stopped connecting again. For this second project I’m also using and I thought that maybe adding a scenario and a webhook is messing with the connection, is that something that can happen? I’m using #define BLYNK_PRINT Serial and Serial.begin(115200); but the device won’t connect and no printing occured. If anyone has advice for me or knows what’s wrong, it would be greatly appreciated. Thank you! here is my code if t helps:

#define BLYNK_AUTH_TOKEN ***

#define DHT_PIN 15
#define DHT_TYPE DHT22
#define LED_PIN 13

#define BLYNK_PRINT Serial

#include <WiFi.h>
#include <WiFiClient.h>
#include <BlynkSimpleEsp32.h>
#include <DHT.h>

float humidity;
long LastHumidityMillis;

void setup() {
  Serial.println("starting program");
  Blynk.begin(BLYNK_AUTH_TOKEN, ssid, pass);
  Serial.println("Blynk connected");
  LastHumidityMillis = millis() - 10000;
void loop() {;

Does that mean the Arduino IDE and an ESP32 dev board, or something else?

I think that if you read the rest of your post, it would be surprising if anyone could offer any useful advice because the information you’ve provided is so vague. Even you don’t seem to know if adding a webhook to your project is causing an issue, which means that nobody else is going to be able to answer that question for you.

The most powerful tool at your disposal is the use of #define BLYNK_PRINT Serial and the subsequent serial monitor output, but you’ve not told us what your serial monitor is showing, or given us any clues about what your sketches look like.

I think you have to be realistic about the type of answers that community members can provide based on the type of information you provide to us.


Thank you, I tried to add more info. I just thought it might be a problem other people encountered. It really is hard for me to explain because it doesn’t make any sense i don’t know why it isn’t connecting when i run the code…

@Roniru Please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:

Copy and paste these if you can’t find the correct symbol on your keyboard.


The code you’ve posted is incomplete because it lacks the checkHumidity function that you’re calling in your void loop.

But, you shouldn’t have that function call in your void loop, you should be calling the function with a BlynkTimer anyway - read this…

If you’re not getting any serial output at all, you should try the following…

  1. ensure your serial monitor is also set to 115200
  2. try a different USB cable
  3. remove all the connections from your board except the USB cable and see if that makes a difference.