Trouble connecting Arduino 101 with iPhone

I have updated the library and the App (iPhone) today but I am still getting “Can’t connect. Please retry or choose another device.” I am trying this with the Blynk LED sketch.

@jlmyra Please don’t interject unrelated “me too” issues into someone else’s topic. I have moved your issue into it’s own topic.

Please clarify your issue… what hardware are you trying to connect too?

Sorry for not following protocol.

I am trying to connect a Arduino 101 to my iPhone via bluetooth - BLE. I have a four motor robot that I have been operating with Blynk for some time. Recently, I am unable to get them to connect. I tried creating a new account, that didn’t help. I tried using the Blynk LED sketch with the new account. The arduino now shows up on the phone but it will not connect - it seems to time out and responds with “Can’t connect. Please retry or choose another device.” I have installed the Blynk app on my phone that came out today (says it fixes BLE connectivity issues) and I installed the updated Blynk library.

What am I missing???


Hello. OK, so you are using an Arduino 101. Same issue then, sorry, it was hard to tell at first. Been seeing a few 101 questions mixed in with other BT/BLE issues.

Turns out there is a bug on Arduino’s / Intel’s end, that is preventing Blynk BLE from working properly with the updated 101 core libraries… or something like that.

“They”, Intel and Arduino, are aware of the issue. Unfortunately, I believe all 101 users will just have to wait until Intel releases the next update to the IDE.

Are known issues posted somewhere? I invested a lot of time trying to work around this issue.

Anyway thanks for your time and help!


For me it is simply a case of reading forum posts daily and hoping to remember the what, where and why as needed :confused:

I am positive that the Blynk developers are sweating away at it as well… This latest update on the Intel issue was just posted by the developers earlier today, so we are not far behind the curve :wink:

1 Like

I purchased an Arduino 101 to work with Blynk over bluetooth from my iPhone. I could not get it to connect so I searched and found this forum thread.

It seems the issue has been around for quite some time. The forum does not list timestamps but I assume this thread is a year old?

Looking at Intel’s site, the last update to the 101 was 3/2016. That does not inspire confidence that they are looking into the issue.

I tried downgrading to 1.07 but the sketch will not upload. It just freezes. Is there any hope of getting Blynk working on my 101 over BLE or is it a lost cause? Any help would be appreciated. Thank you.

Every single post has a time date stamp… far right from your Avatar.

It is an Intel issue… temporary solution is downgrade the Arduino 101 library AND firmware… More info about that in this topic.

Thanks Gunner! I appreciate the reply.

Regarding the timestamp I should have been more specific. It shows the month but not the year…

I did not downgrade the Blynk library as I wasn’t sure which one to use. I may try that, but in the interim I added a WiFi module to my Arduino 101 and that is working for now.

Hopefully the wait will not be too long for the Intel fix…

Hover over it :wink:
[quote=“mtkreitz, post:9, topic:13421”]
I did not downgrade the Blynk library as I wasn’t sure which one to use.

NOT the Blynk Library… the Arduino101 (Curie) library in the IDE… check out that other post! Particularly toward the end.

1 Like