Tried everything but still the problem resides for reconfiguring the device

I am working in a project, created a template and tested the Blynk 2.0 . Now i have changed the template Id and reprogramed the esp32. But problem is as soon as i register the device on blynk, Blynk recognizes the device and shows as offline in mobile app. I tried to reconfigure the Wifi credential but after entering the credentials it shows the connection is interrupted. I tried everything from changing template to updating the Blynk libraries, changed the account, deleted the blynk library and installed it again from Github. I tried almost every thing but the problem still resides.
please let me know how to enter the wifi credential again.
I am just using the Blynk edgent example with my template id and device name.

Click on tile
Once you start to see the dashboard
Click in the three dots on top right corner
That will take you to the information page
Now again click on three dots
That will ask you to ::

Reconfigure
Erase all device data
Delete device

Now, delete the device and start all over again.
Create a new template id from web dash and do the rest as is.

Edit::

What does your serial monitor show ??
Does it shows ping ?
Connecting to cloud
Running ?

Show us your serial monitor output.
Make sure you are entering correct wifi creds.